summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/podofo/files/podofo-0.9.6_pre20171027-libressl-bug-635890.patch26
-rw-r--r--app-text/podofo/podofo-0.9.6_pre20171027.ebuild4
2 files changed, 30 insertions, 0 deletions
diff --git a/app-text/podofo/files/podofo-0.9.6_pre20171027-libressl-bug-635890.patch b/app-text/podofo/files/podofo-0.9.6_pre20171027-libressl-bug-635890.patch
new file mode 100644
index 000000000000..2b25dc7b6856
--- /dev/null
+++ b/app-text/podofo/files/podofo-0.9.6_pre20171027-libressl-bug-635890.patch
@@ -0,0 +1,26 @@
+From 85e66b066de98f38e0430428906d5cf5396876a0 Mon Sep 17 00:00:00 2001
+From: Michelangelo Scopelliti <kernelpanic@gmx.it>
+Date: Thu, 23 Nov 2017 12:29:36 +0000
+Subject: [PATCH] Fix to compile with libressl (does not have OPENSSL_init_ssl)
+
+Bug: https://bugs.gentoo.org/635890
+---
+ tools/podofosign/podofosign.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/podofosign/podofosign.cpp b/tools/podofosign/podofosign.cpp
+index a7be1e5..5c9d146 100644
+--- a/tools/podofosign/podofosign.cpp
++++ b/tools/podofosign/podofosign.cpp
+@@ -875,7 +875,7 @@ int main( int argc, char* argv[] )
+ outputfile = NULL;
+ }
+
+-#ifdef PODOFO_HAVE_OPENSSL_1_1
++#if defined (PODOFO_HAVE_OPENSSL_1_1) && !defined (LIBRESSL_VERSION_NUMBER)
+ OPENSSL_init_ssl(0, NULL);
+ #else
+ OpenSSL_add_all_algorithms();
+--
+2.13.6
+
diff --git a/app-text/podofo/podofo-0.9.6_pre20171027.ebuild b/app-text/podofo/podofo-0.9.6_pre20171027.ebuild
index 67a8f21dd4db..b7e200e657a7 100644
--- a/app-text/podofo/podofo-0.9.6_pre20171027.ebuild
+++ b/app-text/podofo/podofo-0.9.6_pre20171027.ebuild
@@ -29,6 +29,10 @@ DEPEND="${RDEPEND}
boost? ( dev-util/boost-build )
test? ( dev-util/cppunit )"
+PATCHES=(
+ "${FILESDIR}/${P}-libressl-bug-635890.patch"
+)
+
DOCS="AUTHORS ChangeLog TODO"
src_prepare() {