summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch17
-rw-r--r--app-shells/tcsh/tcsh-6.21.00.ebuild1
2 files changed, 18 insertions, 0 deletions
diff --git a/app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch b/app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch
new file mode 100644
index 000000000000..a01ebfb57fdb
--- /dev/null
+++ b/app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch
@@ -0,0 +1,17 @@
+GetCmdChar: fix compilation with --disable-nls
+
+Bug: https://bugs.gentoo.org/689904
+
+--- a/ed.inputl.c
++++ b/ed.inputl.c
+@@ -669,8 +669,8 @@
+ {
+ #ifndef WINNT_NATIVE // We use more than 256 for various extended keys
+- wint_t c = ch & CHAR;
++ eChar c = ch & CHAR;
+ #else
+- wint_t c = ch;
++ eChar c = ch;
+ #endif
+ return c < NT_NUM_KEYS ? CurrentKeyMap[c] : F_INSERT;
+ }
diff --git a/app-shells/tcsh/tcsh-6.21.00.ebuild b/app-shells/tcsh/tcsh-6.21.00.ebuild
index dadd2ea9de5a..c4e52506794f 100644
--- a/app-shells/tcsh/tcsh-6.21.00.ebuild
+++ b/app-shells/tcsh/tcsh-6.21.00.ebuild
@@ -32,6 +32,7 @@ CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
PATCHES=(
"${FILESDIR}"/${PN}-6.20.00-debian-dircolors.patch # bug #120792
"${FILESDIR}"/${PN}-6.18.01-aix.patch
+ "${FILESDIR}"/${PN}-6.21.00-no-nls.patch
)
src_prepare() {