summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cmatrix')
-rw-r--r--app-misc/cmatrix/cmatrix-2.0-r5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/cmatrix/cmatrix-2.0-r5.ebuild b/app-misc/cmatrix/cmatrix-2.0-r5.ebuild
new file mode 100644
index 000000000000..5d79851505fb
--- /dev/null
+++ b/app-misc/cmatrix/cmatrix-2.0-r5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FONT_SUFFIX="pcf"
+
+inherit cmake font
+
+DESCRIPTION="Ncurses based app to show a scrolling screen from the Matrix"
+HOMEPAGE="https://github.com/abishekvashok/cmatrix"
+SRC_URI="https://github.com/abishekvashok/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+unicode"
+
+DEPEND="sys-libs/ncurses:=[unicode(+)?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCURSES_NEED_WIDE=$(usex unicode)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ use X && font_src_install
+ doman ${PN}.1
+}
+
+pkg_postinst() {
+ use X && font_pkg_postinst
+}
+
+pkg_postrm() {
+ use X && font_pkg_postrm
+}