summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/glean')
-rw-r--r--app-emulation/glean/Manifest1
-rw-r--r--app-emulation/glean/glean-1.18.2.ebuild26
-rw-r--r--app-emulation/glean/metadata.xml4
3 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/glean/Manifest b/app-emulation/glean/Manifest
index d3929ac5af78..fe77c58672fb 100644
--- a/app-emulation/glean/Manifest
+++ b/app-emulation/glean/Manifest
@@ -1 +1,2 @@
DIST glean-1.17.0.tar.gz 62791 BLAKE2B 6429bd721655499732f84dc8db4bd31bdb128289956ab65fab78ea5461cf7945ced893fd832ac6a3cdcedb331f3885004eaa530be1ee4fcc4168870b5c345dd3 SHA512 55c8ceae941296c038acff3f40cf4d6b783d7c6530ebd6fbd6d87938de11a1be1403741a559802c9135d3fc4d904b1936319dcf7a0179f95ac3f909667f5622c
+DIST glean-1.18.2.tar.gz 67642 BLAKE2B b346fc63b361e7c7bf0b8fc100da4a047004950aff3e17fce96d47ae5a7887828a09f4b107f2af1afcf9d866e5bc0857049ddd2d9c49413e9fe4b61d1de99fd3 SHA512 de80c06952ebbbc24c8cf198f61be788fb32974652c8253787ed5a165e26bb162b48c84836779420bb7c331edeb50a7796f5a2ff578d2e612068c5fbadd343c7
diff --git a/app-emulation/glean/glean-1.18.2.ebuild b/app-emulation/glean/glean-1.18.2.ebuild
new file mode 100644
index 000000000000..053b990f8ad6
--- /dev/null
+++ b/app-emulation/glean/glean-1.18.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Simple program to write static config from config-drive"
+HOMEPAGE="https://opendev.org/opendev/glean"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}
diff --git a/app-emulation/glean/metadata.xml b/app-emulation/glean/metadata.xml
index 04eb5e5e3c1b..98da0ca88f35 100644
--- a/app-emulation/glean/metadata.xml
+++ b/app-emulation/glean/metadata.xml
@@ -5,6 +5,10 @@
<email>alexxy@gentoo.org</email>
<name>Alexey Shvetsov</name>
</maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
<maintainer type="project">
<email>openstack@gentoo.org</email>
<name>Openstack</name>