summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/cldoc')
-rw-r--r--app-emacs/cldoc/Manifest1
-rw-r--r--app-emacs/cldoc/cldoc-1.16.ebuild20
-rw-r--r--app-emacs/cldoc/files/50cldoc-gentoo.el13
-rw-r--r--app-emacs/cldoc/metadata.xml14
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/cldoc/Manifest b/app-emacs/cldoc/Manifest
new file mode 100644
index 000000000000..045027da16a7
--- /dev/null
+++ b/app-emacs/cldoc/Manifest
@@ -0,0 +1 @@
+DIST cldoc-1.16.el.bz2 16869 SHA256 7f75cb6d05939cced1030b095d8136f4a1d0918981fa1660cba9382edafabf18 SHA512 6b53418252e6c139cca24768b502d58cb9d316fd5778b541306b5e7806e9ddac1d7662e099e7dd90c98932555adaeb8a7481b0a72669d5231c803818133cbacc WHIRLPOOL 79a349253f1d50bb4b068fbeeec363b83c7d1c5f4cf83a2f4b8eead4fc153e2b403afa04a9a1661d4a774ed78a1482a1c8e4c73efdcf29ca37395c694845b511
diff --git a/app-emacs/cldoc/cldoc-1.16.ebuild b/app-emacs/cldoc/cldoc-1.16.ebuild
new file mode 100644
index 000000000000..672e04b6e5fe
--- /dev/null
+++ b/app-emacs/cldoc/cldoc-1.16.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Show Common Lisp operators and variables information in echo area"
+HOMEPAGE="http://homepage1.nifty.com/bmonkey/lisp/index-en.html"
+# taken from http://homepage1.nifty.com/bmonkey/emacs/elisp/cldoc.el
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="app-emacs/slime"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/cldoc/files/50cldoc-gentoo.el b/app-emacs/cldoc/files/50cldoc-gentoo.el
new file mode 100644
index 000000000000..79e11ea0e710
--- /dev/null
+++ b/app-emacs/cldoc/files/50cldoc-gentoo.el
@@ -0,0 +1,13 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'cldoc-mode "cldoc" nil t)
+(autoload 'turn-on-cldoc-mode "cldoc" nil t)
+(add-hook 'lisp-mode-hook 'turn-on-cldoc-mode)
+
+(add-hook 'slime-repl-mode-hook
+ #'(lambda ()
+ (turn-on-cldoc-mode)
+ (define-key slime-repl-mode-map " " nil)))
+(add-hook 'slime-mode-hook
+ #'(lambda () (define-key slime-mode-map " " nil)))
+(setq slime-use-autodoc-mode nil)
diff --git a/app-emacs/cldoc/metadata.xml b/app-emacs/cldoc/metadata.xml
new file mode 100644
index 000000000000..23f59bff4a62
--- /dev/null
+++ b/app-emacs/cldoc/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<herd>common-lisp</herd>
+<longdescription>
+Show Common Lisp operators and variables information in echo area.
+cldoc.el has a database of parameters and results of Common Lisp's
+standard functions, and syntax rules of standard macros and special
+operators. cldoc.el automatically uses SLIME's autodoc facility if
+available to display parameters of user defined functions and macros,
+and the values of global variables.
+</longdescription>
+</pkgmetadata>