summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/zchunk/zchunk-9999.ebuild')
-rw-r--r--app-arch/zchunk/zchunk-9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/app-arch/zchunk/zchunk-9999.ebuild b/app-arch/zchunk/zchunk-9999.ebuild
index 76677dce82f5..e89d8926554d 100644
--- a/app-arch/zchunk/zchunk-9999.ebuild
+++ b/app-arch/zchunk/zchunk-9999.ebuild
@@ -13,11 +13,13 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/zchunk/zchunk.git"
else
SRC_URI="https://github.com/zchunk/zchunk/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="BSD-2"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
app-arch/zstd:=
@@ -25,3 +27,11 @@ DEPEND="
dev-libs/openssl:=
"
RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}