summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.29.75.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 01c7570af682..a6e7997d5c4f 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,3 +2,4 @@ DIST aws-cli-1.29.63.gh.tar.gz 2561207 BLAKE2B 83d1bf59c565ae5035eea0bfff91b2ac4
DIST aws-cli-1.29.68.gh.tar.gz 2565226 BLAKE2B b1f2209738c3a54beac322b14ceb54d31a4288b85038c2778d56d8dcafbabe7a307aa228c96e73faabc0ad2495edb65f701a35eddc506c70f0873f9084177c36 SHA512 d8cafa7560ab0f824b190301d9889d0cfe5d746a9a7edd3b19ad003ee70c5f6cc9a26403ec961826462f5e5509a2e12f8a6a99d851fc97b1e46f44e59294aca2
DIST aws-cli-1.29.73.gh.tar.gz 2569425 BLAKE2B 14950fd5c67726779f621dd039bfb7d3c24ab083530b3923aec52f1433a9110455e7ef5aa529ddad3b576e30d6cdd3d40fc94a14f06638756c7347475d8b8e7e SHA512 2a85489d8052b968a083dbff7f9e31d9ffbfce60617ffdacaa65d5d7a9d4c05e70785f230e2e8b2f92c47be9a0b86147ea76a9ffa588b768818e5e64ef4aa280
DIST aws-cli-1.29.74.gh.tar.gz 2570564 BLAKE2B 6877bc2e2cef5b8c1b871af98e41a0ef3ef911927f7a592342c7ad5e762d820b7c561deef54baf8c657d31c6a742b7eb219f206d860966697716963b311937a8 SHA512 690a6c6fe2fab88bd8353b32fecb04d4fa33aefe574bcc4e0b9ec9f2a3c6decd05d01808f9fd715697bb7db2d7b0a2ac0ac23dc03f26b4e3e40ffa30d0cc9828
+DIST aws-cli-1.29.75.gh.tar.gz 2571561 BLAKE2B e9db44fb596ce0a6e210e80ca08f027db765f0ff0e18281de92deb13b0dca3c5c51fb742488fc3b6c5ec7f659ca8fa3d7629a1e74fa260c2dfffbe6359838025 SHA512 a192b5c859ad60844e7ed2bfcb2fd8fe2d59cee4b518cfdbe2b0aa29498e1e315e2d52d91eb72f4208cd0d1b3df2229eafc939b02448cec787cb24a189162b34
diff --git a/app-admin/awscli/awscli-1.29.75.ebuild b/app-admin/awscli/awscli-1.29.75.ebuild
new file mode 100644
index 000000000000..23ea7d6f6fe7
--- /dev/null
+++ b/app-admin/awscli/awscli-1.29.75.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py::TestHelpPager::test_can_handle_ctrl_c
+ tests/unit/test_help.py::TestHelpPager::test_can_render_contents
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}