summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/logstash-forwarder/logstash-forwarder-0.4.0.ebuild')
-rw-r--r--app-admin/logstash-forwarder/logstash-forwarder-0.4.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/logstash-forwarder/logstash-forwarder-0.4.0.ebuild b/app-admin/logstash-forwarder/logstash-forwarder-0.4.0.ebuild
new file mode 100644
index 000000000000..ddca446b1031
--- /dev/null
+++ b/app-admin/logstash-forwarder/logstash-forwarder-0.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit user
+
+DESCRIPTION="Collects logs locally in preparation for processing elsewhere"
+HOMEPAGE="https://github.com/elastic/logstash-forwarder"
+SRC_URI="https://github.com/elastic/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/go:="
+RDEPEND=""
+
+pkg_setup() {
+ enewgroup logstash
+ enewuser logstash -1 -1 -1 logstash
+}
+
+src_install() {
+ dobin "${PN}"
+ dodir "/etc/${PN}"
+ dodoc "${PN}".conf.example CHANGELOG README.md
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+}
+
+pkg_postinst() {
+ if ! [[ -e /etc/${PN}/${PN}.conf ]]; then
+ elog "Before starting logstash-forwarder create config file at"
+ elog
+ elog " /etc/${PN}/${PN}.conf"
+ elog
+ elog "See example in /usr/share/doc/${PVR} directory. You can remove"
+ elog "-quiet from logstash-forward arguments in /etc/conf.d/${PN} to"
+ elog "until you get working configuration. Search syslog for errors."
+ fi
+}