summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/hcloud/Manifest1
-rw-r--r--app-admin/hcloud/hcloud-1.49.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/hcloud/Manifest b/app-admin/hcloud/Manifest
index 27878eea75b3..fe33993e4d5a 100644
--- a/app-admin/hcloud/Manifest
+++ b/app-admin/hcloud/Manifest
@@ -1,2 +1,3 @@
DIST hcloud-1.47.0.tar.xz 2199764 BLAKE2B 02c06449ab62904b3f21ddaadc6182a965488e72f453b8d03d73b4be8a585ae42a7f1db4012588b8983e77cb181fa1aeff1a778205fc23731bc12565cdea1d7b SHA512 ca5999ef59a3b11e589a6c199f87ff2487b1384dfb6244adf286b84ee7de9dc6cbc4879dc72b6a5196c0f067efa7d3202110471debc4fe020114bf97ea10f9c8
DIST hcloud-1.48.0.tar.xz 2365360 BLAKE2B d5c50ba117c20f93ffca713142e622ca6069cbcd591553344d32baedf0d522688851bddb524c8976d9a08fe5ea81fecc10c24f2c88e5610ea26a86036159b4e0 SHA512 f3e119e2a4016489df1cb5116ff21608fb8188671c625596bfbd7342a51f70e26f9a79f059dd1919bac2a3d1aadcff94166ef7ee8640fd0df3e13ccb770b3fa2
+DIST hcloud-1.49.0.tar.xz 2400804 BLAKE2B 50752dd18c20a0ad5783157d2b51514375d3c14ab945188208043709af1f74109e2adc0d31cbb0cd2b6078f4e2ad22940f81bfb538a4cd4acb93a9c069ee18b9 SHA512 4f26f70d9e90e2cabdbca7d0bebc545117c9b684bf03c263dc2bfca66bd8d2088afdc47ecbb9f835a6ab30700aea75dcb27998d71afd18f803205239dcfb50c4
diff --git a/app-admin/hcloud/hcloud-1.49.0.ebuild b/app-admin/hcloud/hcloud-1.49.0.ebuild
new file mode 100644
index 000000000000..49cedeae2460
--- /dev/null
+++ b/app-admin/hcloud/hcloud-1.49.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A command-line interface for Hetzner Cloud"
+HOMEPAGE="https://github.com/hetznercloud/cli"
+SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.versionPrerelease=gentoo" ./cmd/${PN}
+}
+
+src_test() {
+ ./hcloud version
+ if [[ $? -ne 0 ]]
+ then
+ die "hcloud version test failed"
+ fi
+
+ # Avoid error like:
+ # -buildmode=pie not supported when -race is enabled on linux/amd64
+ GOFLAGS=${GOFLAGS//-buildmode=pie}
+ ego test -coverpkg=./... -coverprofile=coverage.txt -v -race ./...
+}
+
+src_install() {
+ dobin ${PN}
+}