summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild18
1 files changed, 1 insertions, 17 deletions
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
index ac7282a691dd..8c0dda871d11 100644
--- a/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
+++ b/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
@@ -13,8 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-REQUIRED_USE="test? ( doc )"
+IUSE="test"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
@@ -35,11 +34,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
>=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
)
- doc? (
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- )
"
RDEPEND="
${CDEPEND}
@@ -57,22 +51,12 @@ RDEPEND="
"
python_prepare_all() {
- sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
python_test() {
testr init
testr run || die "testsuite failed under python2.7"
flake8 tests && einfo "run flake8 over tests folder passed" || die
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- distutils-r1_python_install_all
-}