summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pypy3/pypy3-7.3.9_p5-r1.ebuild (renamed from dev-python/pypy3/pypy3-7.3.9_p5.ebuild)2
-rw-r--r--eclass/ruby-ng.eclass2
-rw-r--r--eclass/ruby-single.eclass6
-rw-r--r--net-im/zoom/Manifest2
-rw-r--r--net-im/zoom/zoom-5.11.9.4300.ebuild (renamed from net-im/zoom/zoom-5.11.1.3595.ebuild)4
-rw-r--r--profiles/base/use.mask4
6 files changed, 6 insertions, 14 deletions
diff --git a/dev-python/pypy3/pypy3-7.3.9_p5.ebuild b/dev-python/pypy3/pypy3-7.3.9_p5-r1.ebuild
index 1574588f1f3f..c205718e71f2 100644
--- a/dev-python/pypy3/pypy3-7.3.9_p5.ebuild
+++ b/dev-python/pypy3/pypy3-7.3.9_p5-r1.ebuild
@@ -98,7 +98,7 @@ src_compile() {
[[ ${soabi} == ${SLOT#*/} ]] || die "update subslot to ${soabi}"
# Add epython.py to the distribution
- echo "EPYTHON='${EPYTHON}'" > lib-python/3/epython.py || die
+ echo 'EPYTHON="pypy3"' > lib-python/3/epython.py || die
einfo "Generating caches and CFFI modules ..."
diff --git a/eclass/ruby-ng.eclass b/eclass/ruby-ng.eclass
index 06548392a501..6eceb4d5ba9f 100644
--- a/eclass/ruby-ng.eclass
+++ b/eclass/ruby-ng.eclass
@@ -114,7 +114,7 @@ _ruby_get_all_impls() {
for i in ${USE_RUBY}; do
case ${i} in
# removed implementations
- ruby19|ruby20|ruby21|ruby22|ruby23|ruby24|ruby25|jruby)
+ ruby19|ruby20|ruby21|ruby22|ruby23|ruby24|ruby25|ruby26|jruby)
;;
*)
echo ${i};;
diff --git a/eclass/ruby-single.eclass b/eclass/ruby-single.eclass
index 1e390b9163ad..476d16b5cae1 100644
--- a/eclass/ruby-single.eclass
+++ b/eclass/ruby-single.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: ruby-single.eclass
@@ -18,7 +18,7 @@
# pull in the dependency on the requested ruby targets.
#
# @CODE
-# USE_RUBY="ruby26 ruby27"
+# USE_RUBY="ruby27 ruby30"
# inherit ruby-single
# RDEPEND="${RUBY_DEPS}"
# @CODE
@@ -67,7 +67,7 @@ inherit ruby-utils
#
# Example value:
# @CODE
-# || ( dev-lang/ruby:2.7 dev-lang/ruby:2.6 ) virtual/rubygems
+# || ( dev-lang/ruby:3.0 dev-lang/ruby:2.7 ) virtual/rubygems
# @CODE
#
# The order of dependencies will change over time to best match the
diff --git a/net-im/zoom/Manifest b/net-im/zoom/Manifest
index e0e76f3d6416..94c794d9743e 100644
--- a/net-im/zoom/Manifest
+++ b/net-im/zoom/Manifest
@@ -1,2 +1,2 @@
-DIST zoom-5.11.1.3595_x86_64.tar.xz 131583416 BLAKE2B 9848b198bc8c523287e68d85ec42bbb5c1fc6448210c4104273bf6680f4fa2f460a5f880f07d6d5d65aa83cd58c82b071be83205e505c097c205370cd1304c35 SHA512 9e02dcbd33369334521cc51f8a64db1f677fe887773fa73e4ade10f01a0e0ac48cce3ff6ce962d52208935ecf19f82c22c9d81702e9839c30f0cdaa3fd9fde4e
DIST zoom-5.11.3.3882_x86_64.tar.xz 132055676 BLAKE2B bef2b6eadcc2595e3cf4c004f2faf94831d5b1b4289b49654c16030276804893bf5f7192cfd437e28470ba5b891933321a76792e8d8588416ac0284d8654a856 SHA512 56c67ce44a88ec01732150b17b81ad9109329fa0f833eefcd32c5c029eb47928371571296745ae458147953cb9109f5622de1040d0f5bac70e118ae6a4ee18da
+DIST zoom-5.11.9.4300_x86_64.tar.xz 132589368 BLAKE2B 44232cb69d69f2be15639d7c633a311645d645b93e9c367e74ab3df5153b9cbbe2ac8d8554849d56b8512b50357637aa9134893174014571929a6deb6fdba0c9 SHA512 421ad949f9e3a266170864551336f40daeb6e72979174ec8fc796eadb5e5b132f7267c812d92a845fa9d5ca94aacc047336ab655246d8de56b7844432952811b
diff --git a/net-im/zoom/zoom-5.11.1.3595.ebuild b/net-im/zoom/zoom-5.11.9.4300.ebuild
index de370171be34..e80ae876cb3b 100644
--- a/net-im/zoom/zoom-5.11.1.3595.ebuild
+++ b/net-im/zoom/zoom-5.11.9.4300.ebuild
@@ -166,10 +166,6 @@ src_install() {
actions should help:
\\n- Enable compositing in your window manager if it is supported
\\n- Alternatively, run the xcompmgr command (from x11-misc/xcompmgr)"
- use wayland \
- && DOC_CONTENTS+="\\n\\nTo enable screen sharing on GNOME Wayland,
- edit ~/.config/zoomus.conf and change the value of
- enableWaylandShare to true."
readme.gentoo_create_doc
}
diff --git a/profiles/base/use.mask b/profiles/base/use.mask
index b777369fddc1..9f1309be64db 100644
--- a/profiles/base/use.mask
+++ b/profiles/base/use.mask
@@ -9,10 +9,6 @@
# change. bug #838970.
qt6
-# Hans de Graaff <graaff@gentoo.org> (2022-07-16)
-# Mask ruby 2.6 as EOL
-ruby_targets_ruby26
-
# Matt Turner <mattst88@gentoo.org> (2022-04-16)
# dev-util/sysprof not keyworded on most arches yet
sysprof