summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/sisctrl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/sisctrl')
-rw-r--r--x11-misc/sisctrl/Manifest1
-rw-r--r--x11-misc/sisctrl/files/sisctrl-0.0.20051202-no-xv.patch12
-rw-r--r--x11-misc/sisctrl/metadata.xml5
-rw-r--r--x11-misc/sisctrl/sisctrl-0.0.20051202.ebuild32
4 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/sisctrl/Manifest b/x11-misc/sisctrl/Manifest
new file mode 100644
index 000000000000..35987ca4a0a0
--- /dev/null
+++ b/x11-misc/sisctrl/Manifest
@@ -0,0 +1 @@
+DIST sisctrl-0.0.20051202.tar.gz 666749 SHA256 76855a8ff4631418374261613a273b082e0f56f29aa083a2197c5350688611f1 SHA512 26fe6561c2c14ff6cf952b89b8089b4fbdbc0c142bbcbf1358afe610b219a05dcf4d0bc835365cd0cf13558fed142b8aa2a0aa91c4fec8f40f0fc82590feabd1 WHIRLPOOL ec5dcf2b2286b99716cea4625d2124490e56c8ab743f0d068811b9a63f59533eaf924606b0fca3741b3abccbe91050c8ea7b2e66f40a70f256669ac981cbeda7
diff --git a/x11-misc/sisctrl/files/sisctrl-0.0.20051202-no-xv.patch b/x11-misc/sisctrl/files/sisctrl-0.0.20051202-no-xv.patch
new file mode 100644
index 000000000000..6c61b8485bc2
--- /dev/null
+++ b/x11-misc/sisctrl/files/sisctrl-0.0.20051202-no-xv.patch
@@ -0,0 +1,12 @@
+--- a/src/sisctrl.c
++++ b/src/sisctrl.c
+@@ -4067,7 +4067,9 @@
+ ( (!(sc.sdflags & SiS_SD_SUPPORT2OVL)) || (sc.sd2flags & SiS_SD2_SUPPORT760OO) ) ) ?
+ 1 : 0;
+
++#ifdef USEXV
+ gl.noxvdemo = (sc.noxvdemo) ? 1 : 0;
++#endif
+
+ #ifdef USE_STRAY
+ gl.dontusesystemtray = sc.dontusesystemtray;
diff --git a/x11-misc/sisctrl/metadata.xml b/x11-misc/sisctrl/metadata.xml
new file mode 100644
index 000000000000..2518313f5241
--- /dev/null
+++ b/x11-misc/sisctrl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/sisctrl/sisctrl-0.0.20051202.ebuild b/x11-misc/sisctrl/sisctrl-0.0.20051202.ebuild
new file mode 100644
index 000000000000..548f712a1958
--- /dev/null
+++ b/x11-misc/sisctrl/sisctrl-0.0.20051202.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic
+
+DESCRIPTION="tool that allows you to tune SiS drivers from X"
+HOMEPAGE="http://www.winischhofer.net/linuxsispart1.shtml#sisctrl"
+SRC_URI="http://www.winischhofer.net/sis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libXrender
+ x11-libs/libXv
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xf86vidmodeproto"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-xv.patch
+ sed -i -e 's,/X11R6,,g' configure || die
+ append-flags -lm
+}