summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-11-01 07:15:21 +0000
committerJoonas Niilola <juippis@gentoo.org>2022-11-18 10:51:34 +0200
commit716625902a1f17d2ae3db671eaf0759b1d7e9887 (patch)
tree91d37d16e6580aeee709f5a72a301e28e40cd803 /www-apps
parentdev-python/mitmproxy_wireguard: Keyword 0.1.16 arm64, #881731 (diff)
downloadgentoo-716625902a1f17d2ae3db671eaf0759b1d7e9887.tar.gz
gentoo-716625902a1f17d2ae3db671eaf0759b1d7e9887.tar.bz2
gentoo-716625902a1f17d2ae3db671eaf0759b1d7e9887.zip
www-apps/kibana-bin: bump to 7.17.7
Closes: https://bugs.gentoo.org/869500 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/kibana-bin/Manifest1
-rw-r--r--www-apps/kibana-bin/kibana-bin-7.17.7.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/www-apps/kibana-bin/Manifest b/www-apps/kibana-bin/Manifest
index 93c7c616956e..87ad345d33f8 100644
--- a/www-apps/kibana-bin/Manifest
+++ b/www-apps/kibana-bin/Manifest
@@ -1 +1,2 @@
DIST kibana-7.17.5-linux-x86_64.tar.gz 263788794 BLAKE2B 7399fbfd5ce6c47421ec3f713dd5b12de5b32dd143ee980169c3fb2f4b7d00e6d9cc5a892e40b2efe28bb9148644d8dc921f753a33f941aee3ca90cb1f7eb7f4 SHA512 a1a00934b9ddd318b66129f682d8d678c51ff3c79b1953f72a72bd00d28600ef465e201e5ed434c31764a09cebcf5e76ae21d99915b5955158d573e6adffc2d7
+DIST kibana-7.17.7-linux-x86_64.tar.gz 264223742 BLAKE2B b433bbf080945ed5ded7862e5fb119a4672c5b5f6b58d6ae6bed8768ad1d8ed6435131c2174c39a18704bad75af150678056f30ae8046ebd1a9cd6737c04cbba SHA512 8d8250a73f3e6f208dfb02f9e1e19efed6c063bb50d6b802ab7b7e7f6d3c49dff287beb126b8663f02c7dbcff7936f7c27a79d441bc2e7e0e6b12ce521a85441
diff --git a/www-apps/kibana-bin/kibana-bin-7.17.7.ebuild b/www-apps/kibana-bin/kibana-bin-7.17.7.ebuild
new file mode 100644
index 000000000000..366cfd12f858
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-7.17.7.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Analytics and search dashboard for Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/kibana"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 Artistic-2 BSD BSD-2 CC-BY-3.0 CC-BY-4.0 Elastic-2.0 icu ISC MIT MPL-2.0 OFL-1.1 openssl public-domain Unlicense WTFPL-2 ZLIB"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ acct-group/kibana
+ acct-user/kibana
+ dev-libs/expat
+ dev-libs/nspr
+ dev-libs/nss
+ >=net-libs/nodejs-16.13.0
+ <net-libs/nodejs-18
+ sys-libs/glibc
+"
+
+# Do not complain about CFLAGS etc since we don't use them
+QA_FLAGS_IGNORED='.*'
+QA_PRESTRIPPED="
+ opt/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_x64/headless_shell
+ opt/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_x64/swiftshader/libEGL.so
+ opt/kibana/x-pack/plugins/reporting/chromium/headless_shell-linux_x64/swiftshader/libGLESv2.so
+ opt/kibana/node_modules/re2/build/Release/re2.node
+"
+
+S="${WORKDIR}/${MY_P}-linux-x86_64"
+
+src_prepare() {
+ default
+
+ # remove unused directory
+ rm -r data || die
+
+ # remove bundled nodejs
+ rm -r node || die
+ sed -i 's@\(^NODE="\).*@\1/usr/bin/node"@g' \
+ bin/kibana || die
+
+ # move plugins to /var/lib/kibana
+ rm -r plugins || die
+
+ # handle node.js version with RDEPEND
+ sed -i /node_version_validator/d \
+ src/setup_node_env/no_transpilation_dist.js || die
+}
+
+src_install() {
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -r config || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
+
+ newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.initd-r1 ${MY_PN}
+ systemd_dounit "${FILESDIR}"/${MY_PN}.service
+
+ insinto /opt/${MY_PN}
+ doins -r .
+
+ fperms -R +x /opt/${MY_PN}/bin
+
+ diropts -m 0750 -o ${MY_PN} -g ${MY_PN}
+ keepdir /var/lib/${MY_PN}/plugins
+ keepdir /var/log/${MY_PN}
+
+ dosym ../../var/lib/kibana/plugins /opt/kibana/plugins
+}
+
+pkg_postinst() {
+ elog "This version of Kibana is compatible with Elasticsearch $(ver_cut 1-2) and"
+ elog "Node.js 16. Some plugins may fail with other versions of Node.js (Bug #656008)."
+ elog
+ elog "To set a customized Elasticsearch instance:"
+ elog " OpenRC: set ES_INSTANCE in /etc/conf.d/${MY_PN}"
+ elog " systemd: set elasticsearch.url in /etc/${MY_PN}/kibana.yml"
+ elog
+ elog "Elasticsearch can run local or remote."
+}