summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-04 05:16:11 +0100
committerSam James <sam@gentoo.org>2023-05-04 05:33:19 +0100
commit80472c8edebf975ba22402bf16e776cbfe79d534 (patch)
tree48d5490d6de2b74e29591abf2646de9a8746fba1 /sys-apps
parentdev-util/codeblocks: Stabilize 20.03-r6 x86, #905663 (diff)
downloadgentoo-80472c8edebf975ba22402bf16e776cbfe79d534.tar.gz
gentoo-80472c8edebf975ba22402bf16e776cbfe79d534.tar.bz2
gentoo-80472c8edebf975ba22402bf16e776cbfe79d534.zip
sys-apps/moar: add 1.14.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.14.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index 256dea1116ad..07b731959a47 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -2,3 +2,5 @@ DIST moar-1.12.0-deps.tar.xz 26291664 BLAKE2B ebc16cbe23c26eacd84376b6e99d7484c7
DIST moar-1.12.0.tar.gz 2777752 BLAKE2B fa2f442e2b0e6d909e77be8df873c7b08a82b43d881583a7f1c4a3591f2bbe90b5adc77524b92e0fcf071ce4a1c18d8c58c7cce18807974fae7342148d7fbe28 SHA512 bfa15f5fd3ffa4146adec9110fbf8fd3bc31c95877f5e24ab911d1ef9e357dd41b46e2f466f2ce7d2fc986e463dcf2e1132c0a42ebfe2c46a8cd216355c4b98b
DIST moar-1.13.0-deps.tar.xz 4808044 BLAKE2B cd7808337af5acb2bd6cb4b9696c9d04803df033b5a1d4904418602dc629cef7c16172b0eaa57644be76a02b6727d36f767bfafba1377ea95eb827fbb4a1d34b SHA512 e51ca15137f4b5dc5ea447c200341aaeb06cd77118cd8f2fb3efca0ffc2d4199e00687f980803c4ff09c535621b58206b22bff2c944ad8786c73c3a7c886d6c6
DIST moar-1.13.0.tar.gz 2778084 BLAKE2B 6f3dfc1b997c0176b57e613a822df4f25d7bb509ce245d3c9711bebc4dfccee4d423ce02dbf2845377b856a909cc9e5d8f88d9c65a85d8830bd713ef93729250 SHA512 fca30d496c2439cf5d1204eaa5c5114ef13522f38c8ddcc771ea45aee5faafb5aaf48a8947ff7d5846556130368625f47e851c2494489eb9371807eabb4c7c49
+DIST moar-1.14.0-deps.tar.xz 4808044 BLAKE2B cd7808337af5acb2bd6cb4b9696c9d04803df033b5a1d4904418602dc629cef7c16172b0eaa57644be76a02b6727d36f767bfafba1377ea95eb827fbb4a1d34b SHA512 e51ca15137f4b5dc5ea447c200341aaeb06cd77118cd8f2fb3efca0ffc2d4199e00687f980803c4ff09c535621b58206b22bff2c944ad8786c73c3a7c886d6c6
+DIST moar-1.14.0.tar.gz 2780033 BLAKE2B 42e985aef677830782e70c60748ce732a572352dad629126873bd9532314924ba4e8afc2be4ced0d3161b00b5d4088782908ee7a2f24d670aaf7ddf243473fb6 SHA512 ec0e851f031a03d8af3c4b8b11be2eab300d46adb08fd366d41c958f0d2227fb82800974af3fda72ac01a79e4d2c65e41816b2f1c4ec3b3c7534aeb9b9ded51e
diff --git a/sys-apps/moar/moar-1.14.0.ebuild b/sys-apps/moar/moar-1.14.0.ebuild
new file mode 100644
index 000000000000..177f577621ac
--- /dev/null
+++ b/sys-apps/moar/moar-1.14.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI=" https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="!dev-lang/moarvm"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}