summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-24 01:47:31 +0100
committerSam James <sam@gentoo.org>2024-06-24 01:47:31 +0100
commit279b62199c9285e390a843b0ed08957059ce6bf4 (patch)
tree13e34e36d1cfa9d8fd1ffae60602bdf67936771b /sys-apps/mawk
parentsys-apps/coreutils: skip dd/no-allocate.sh again (diff)
downloadgentoo-279b62199c9285e390a843b0ed08957059ce6bf4.tar.gz
gentoo-279b62199c9285e390a843b0ed08957059ce6bf4.tar.bz2
gentoo-279b62199c9285e390a843b0ed08957059ce6bf4.zip
sys-apps/mawk: add 1.3.4_p20240622
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/mawk')
-rw-r--r--sys-apps/mawk/Manifest2
-rw-r--r--sys-apps/mawk/mawk-1.3.4_p20240622.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/mawk/Manifest b/sys-apps/mawk/Manifest
index 42bf388b278e..c7bf7566c03d 100644
--- a/sys-apps/mawk/Manifest
+++ b/sys-apps/mawk/Manifest
@@ -2,3 +2,5 @@ DIST mawk-1.3.4-20231126.tgz 413452 BLAKE2B e3907cf88ea3daaaf8a1d12eb9fe3cb726be
DIST mawk-1.3.4-20231126.tgz.asc 729 BLAKE2B 72d8e626aac6354f2e568eb118f2d19b3d770ab8b23449163e84941cdbd8539b0e39edb0446176fc64ecfe2deac81e98f1107df1bdbd815569bf5d6b08d72cc3 SHA512 19a9725f84651f87ecb38350984a60fce52046df45be7c494e615db91f6b76229d3dba20211bca41b90a7370fbba97fcb7bb2fe475ffb880fac7f1116f14333f
DIST mawk-1.3.4-20240123.tgz 413943 BLAKE2B 29a9c89995e969a62bd0b30e494c67e53aea0466c9286e2005422a54a44bef661ef6223522c4b51bc49b83c56512ae47e784c237dd39dfef77b7aa13ec33973a SHA512 f6d5da44280afeac4a9bb6d3788ed71ee816daaa5816f49b9d40add5292f3ae06e5af007a6c993d14405238cbb70ba4997fdd2fcd5901c9a1a4b61357045c4a6
DIST mawk-1.3.4-20240123.tgz.asc 729 BLAKE2B e4ba4ddd1f3227a9dc922a1325b00fac2d9c95a848fdc03f57eaa5f354bf45da218cbf6e931b5c1464b799c05d10ff7fe95d1eb81221b4afba468bedc7805815 SHA512 3b4b8b8b7b74aff7061158a7c284d1949c09d52d78003b678c9dcc1da036a4d84b873103d76362866daf914d5a7d717c71baf13d30d7e882b03c5f87c8e4c452
+DIST mawk-1.3.4-20240622.tgz 414190 BLAKE2B 3238e633546ea04b0e3822271fcd37d1ac6ae3924c9e7655ff14c9fa35d691ba27bb779e7c1b7f95a46c0aa90b75a71ab2681763c89812f55773e97489e03ff8 SHA512 29fed436502531e226af5e04bc54c2f4f9430c80d863f27e520401577c1f03a10d8a0d9def94c71ca43de40a7b1f450340802de37a7276bfe91d029779b1460e
+DIST mawk-1.3.4-20240622.tgz.asc 729 BLAKE2B b57d41b6062a51d18525abce1c1d463debe032fe05dea9f9ac82f49cae12b7190cdcdb59ef69757b1372d777353ab3cae7a38177e99f684550bf31f85fd3eb56 SHA512 a97297424dea27207b49b51fd1461c9a158dd9a4e5289e91194beebe67a35b3b9fbb414cf8367eae296688038264f1e7b6d69a00903f9c88d0b90d32fc154ae3
diff --git a/sys-apps/mawk/mawk-1.3.4_p20240622.ebuild b/sys-apps/mawk/mawk-1.3.4_p20240622.ebuild
new file mode 100644
index 000000000000..8259c09ce3d6
--- /dev/null
+++ b/sys-apps/mawk/mawk-1.3.4_p20240622.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/thomasdickey.asc
+inherit toolchain-funcs verify-sig
+
+MY_P="${P/_p/-}"
+DESCRIPTION="An (often faster than gawk) awk-interpreter"
+HOMEPAGE="https://invisible-island.net/mawk/mawk.html"
+SRC_URI="https://invisible-mirror.net/archives/${PN}/${MY_P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${MY_P}.tgz.asc )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-thomasdickey-20240114 )"
+
+DOCS=( ACKNOWLEDGMENT CHANGES README )
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ arc4random_push # doesn't exist on Linux
+)
+
+src_configure() {
+ tc-export BUILD_CC
+ econf
+}
+
+src_install() {
+ default
+
+ exeinto /usr/share/doc/${PF}/examples
+ doexe examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ if has_version app-admin/eselect && has_version app-eselect/eselect-awk; then
+ eselect awk update ifunset
+ fi
+}
+
+pkg_postrm() {
+ if has_version app-admin/eselect && has_version app-eselect/eselect-awk; then
+ eselect awk update ifunset
+ fi
+}