summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/checkpolicy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/checkpolicy')
-rw-r--r--sys-apps/checkpolicy/Manifest3
-rw-r--r--sys-apps/checkpolicy/checkpolicy-2.2.ebuild47
-rw-r--r--sys-apps/checkpolicy/checkpolicy-2.3.ebuild51
-rw-r--r--sys-apps/checkpolicy/checkpolicy-2.4.ebuild51
-rw-r--r--sys-apps/checkpolicy/checkpolicy-9999.ebuild58
-rw-r--r--sys-apps/checkpolicy/metadata.xml6
6 files changed, 216 insertions, 0 deletions
diff --git a/sys-apps/checkpolicy/Manifest b/sys-apps/checkpolicy/Manifest
new file mode 100644
index 000000000000..b87acc90e1c8
--- /dev/null
+++ b/sys-apps/checkpolicy/Manifest
@@ -0,0 +1,3 @@
+DIST checkpolicy-2.2.tar.gz 64458 SHA256 9ff6698f4d4cb59c9c916e348187d533ada4107f90c253ef7304905934e9adf8 SHA512 a6f70e1b6581673af515d7d192237e2d47c0e07bb589c64b92f90f3a450ef8c312eabc2384479faed8bb909b98c15b676cea77e7dcb5304a51314601e93bef59 WHIRLPOOL 18c13139e8b75bb5bd45a9ddbf0c17c07fa86da66e792ece4a1d1204d211766fec27f6fce7db248957e7d2b2847c91b4c9d0ef45cf64e106aee52bc29be7992c
+DIST checkpolicy-2.3.tar.gz 64970 SHA256 90632d11afecb66997971d4c5c5d70dfb02d3969ec610ee2918ba6df99c8207b SHA512 9b10cee8ec9d555c810712131eec0e7e1bf900e4675804b8f57b04988543ba784f4bf76030f196868cef91a1c4ec370f77da12ef9e79362bf7a1cc38c7cafcff WHIRLPOOL 49ca9fa1695bedf141d397ca679ba769b748dc39ec7d462718f6b90af9c31c1da64d1ff67b3b4e426f758a9d305dc9e19d755e1127bfcd5e492dccf09ac75d09
+DIST checkpolicy-2.4.tar.gz 65238 SHA256 9bbdac28a88de4c405c769730863f3adcd266adbfa45881a5de67e3a4895bcd4 SHA512 8c5c22d9510305e7f518d1a5818f5b36895210f48835d8d24a43b2d34e79881cebcc8cd588bb663c0613a4f878db125c22a4b4df3d0f63b8fb8f88350abc61cc WHIRLPOOL b717428b4411e526cc47ed2be88d7e7e4d48153404b90d50e510fd0cc10cc0452661d0b6b0cc200bb09ae1cc040ae59aae68a8c748611db3ca4cd262f8e8f932
diff --git a/sys-apps/checkpolicy/checkpolicy-2.2.ebuild b/sys-apps/checkpolicy/checkpolicy-2.2.ebuild
new file mode 100644
index 000000000000..8cfc1969e608
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+SEPOL_VER="2.2"
+SEMNG_VER="2.2"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20131030/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libsemanage-${SEMNG_VER}
+ sys-devel/flex
+ sys-devel/bison"
+
+RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" YACC="bison -y" || die
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use debug; then
+ dobin "${S}/test/dismod"
+ dobin "${S}/test/dispol"
+ fi
+}
+
+pkg_postinst() {
+ einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
+}
diff --git a/sys-apps/checkpolicy/checkpolicy-2.3.ebuild b/sys-apps/checkpolicy/checkpolicy-2.3.ebuild
new file mode 100644
index 000000000000..9803a129eb80
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+MY_P="${P//_/-}"
+
+SEPOL_VER="2.3"
+SEMNG_VER="2.3"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20140506/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libsemanage-${SEMNG_VER}
+ sys-devel/flex
+ sys-devel/bison"
+
+RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" YACC="bison -y" || die
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use debug; then
+ dobin "${S}/test/dismod"
+ dobin "${S}/test/dispol"
+ fi
+}
+
+pkg_postinst() {
+ einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
+}
diff --git a/sys-apps/checkpolicy/checkpolicy-2.4.ebuild b/sys-apps/checkpolicy/checkpolicy-2.4.ebuild
new file mode 100644
index 000000000000..6c71b0dc1216
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-2.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+MY_P="${P//_/-}"
+
+SEPOL_VER="${PV}"
+SEMNG_VER="${PV}"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20150202/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libsemanage-${SEMNG_VER}
+ sys-devel/flex
+ sys-devel/bison"
+
+RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" YACC="bison -y" LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use debug; then
+ dobin "${S}/test/dismod"
+ dobin "${S}/test/dispol"
+ fi
+}
+
+pkg_postinst() {
+ einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
+}
diff --git a/sys-apps/checkpolicy/checkpolicy-9999.ebuild b/sys-apps/checkpolicy/checkpolicy-9999.ebuild
new file mode 100644
index 000000000000..0d877e0cc8fb
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20150202"
+
+SEPOL_VER="${PV}"
+SEMNG_VER="${PV}"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://userspace.selinuxproject.org"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ >=sys-libs/libsemanage-${SEMNG_VER}
+ sys-devel/flex
+ sys-devel/bison"
+
+RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" YACC="bison -y" LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use debug; then
+ dobin "${S}/test/dismod"
+ dobin "${S}/test/dispol"
+ fi
+}
+
+pkg_postinst() {
+ einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
+}
diff --git a/sys-apps/checkpolicy/metadata.xml b/sys-apps/checkpolicy/metadata.xml
new file mode 100644
index 000000000000..92f48e017202
--- /dev/null
+++ b/sys-apps/checkpolicy/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>selinux</herd>
+ <longdescription>SELinux policy compilier</longdescription>
+</pkgmetadata>