summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-17 16:09:24 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-17 16:11:39 +0200
commitda26589a40637b2f1fceef6180b3de18351a4610 (patch)
tree7d105527383ca77409610c810f946df58b182a78 /sci-libs
parentsci-libs/geos: Allow for compiling with GCC 6 (diff)
downloadgentoo-da26589a40637b2f1fceef6180b3de18351a4610.tar.gz
gentoo-da26589a40637b2f1fceef6180b3de18351a4610.tar.bz2
gentoo-da26589a40637b2f1fceef6180b3de18351a4610.zip
sci-libs/cifparse-obj: Allow for compiling with GCC 6
Gentoo-bug: 594054 * Remove broken declarations of the 'strcasecmp' and 'strncasecmp' functions. Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild5
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-strncasecmp-declaration.patch16
2 files changed, 19 insertions, 2 deletions
diff --git a/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild b/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild
index a30d3b402d53..39d176203c73 100644
--- a/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild
+++ b/sci-libs/cifparse-obj/cifparse-obj-7.025-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,7 +29,8 @@ src_prepare() {
"${FILESDIR}"/${P}-makefile.patch \
"${FILESDIR}"/${P}-gcc4.3.patch \
"${FILESDIR}"/${P}-gcc4.7.patch \
- "${FILESDIR}"/${P}-gcc5.patch
+ "${FILESDIR}"/${P}-gcc5.patch \
+ "${FILESDIR}"/${PN}-7.025-strncasecmp-declaration.patch
sed \
-e "s:^\(CC=\).*:\1$(tc-getCC):g" \
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-strncasecmp-declaration.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-strncasecmp-declaration.patch
new file mode 100644
index 000000000000..9222ff27699e
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-strncasecmp-declaration.patch
@@ -0,0 +1,16 @@
+Remove incorrect prototypes of the 'strcasecmp' and 'strncasecmp' functions.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=594054
+
+--- a/misclib-v2.2/include/ndb_misclib.h
++++ b/misclib-v2.2/include/ndb_misclib.h
+@@ -167,10 +167,6 @@
+ #define NDB_MSG_BUFFER_LEN 200000
+
+
+-#if !defined(HAVE_STRCASECMP)
+-int strcasecmp (const char *s1, const char *s2);
+-int strncasecmp (const char *s1, const char *s2, unsigned int n);
+-#endif
+ /*
+ * ndb_misclib.c prototypes
+ */