summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-29 00:47:12 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-29 00:51:32 +0200
commit968e6a0bcb47baa93568b213a8f4bf5bfd2d2183 (patch)
tree3452c497d3637e091f3436172f6767a751c311ca /sci-libs
parentnet-misc/curl: remove einfo banner header (diff)
downloadgentoo-968e6a0bcb47baa93568b213a8f4bf5bfd2d2183.tar.gz
gentoo-968e6a0bcb47baa93568b213a8f4bf5bfd2d2183.tar.bz2
gentoo-968e6a0bcb47baa93568b213a8f4bf5bfd2d2183.zip
sci-libs/colpack: Allow for compiling with GCC 6
Gentoo-bug: 594388 * EAPI=6 * Delete .la files when USE="-static-libs" Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/colpack/colpack-1.0.9-r1.ebuild57
-rw-r--r--sci-libs/colpack/files/colpack-1.0.8-no-bin.patch4
-rw-r--r--sci-libs/colpack/files/colpack-1.0.9-fix-c++14.patch71
3 files changed, 130 insertions, 2 deletions
diff --git a/sci-libs/colpack/colpack-1.0.9-r1.ebuild b/sci-libs/colpack/colpack-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..d2555c338d1a
--- /dev/null
+++ b/sci-libs/colpack/colpack-1.0.9-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+MY_PN="ColPack"
+
+DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
+LICENSE="GPL-3 LGPL-3"
+HOMEPAGE="http://www.cscapes.org/coloringpage/software.htm"
+SRC_URI="http://cscapes.cs.purdue.edu/download/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+SLOT="0"
+IUSE="openmp static-libs"
+KEYWORDS="~alpha ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.6-flags.patch"
+ "${FILESDIR}/${PN}-1.0.8-no-bin.patch"
+ "${FILESDIR}/${PN}-1.0.9-fix_gcc49_omp.patch"
+ "${FILESDIR}/${PN}-1.0.9-fix-c++14.patch"
+)
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using gcc without OpenMP"
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable openmp)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}
diff --git a/sci-libs/colpack/files/colpack-1.0.8-no-bin.patch b/sci-libs/colpack/files/colpack-1.0.8-no-bin.patch
index f2400d66dd07..e9230b0ff105 100644
--- a/sci-libs/colpack/files/colpack-1.0.8-no-bin.patch
+++ b/sci-libs/colpack/files/colpack-1.0.8-no-bin.patch
@@ -1,8 +1,8 @@
From: Sebastien Fabbro <bicatali@gentoo.org>
Avoid installing the ColPack binary on an absolute path
---- Makefile.am 2012-03-20 21:37:34.000000000 -0700
-+++ Makefile.am 2012-09-17 14:24:02.168309078 -0700
+--- a/Makefile.am
++++ b/Makefile.am
@@ -17,8 +17,7 @@
LDADD = libColPack.la
AM_DEFAULT_SOURCE_EXT = .cpp
diff --git a/sci-libs/colpack/files/colpack-1.0.9-fix-c++14.patch b/sci-libs/colpack/files/colpack-1.0.9-fix-c++14.patch
new file mode 100644
index 000000000000..7076be5426a3
--- /dev/null
+++ b/sci-libs/colpack/files/colpack-1.0.9-fix-c++14.patch
@@ -0,0 +1,71 @@
+From 44851d9e90d9847fbfeaaea7b0ed1e7c3d093dcb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <me@besser82.io>
+Date: Wed, 24 Feb 2016 23:26:20 +0100
+Subject: [PATCH] fix semantic errors in error-msgs
+
+---
+ Utilities/extra.cpp | 12 +++++-------
+ 1 file changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/Utilities/extra.cpp b/Utilities/extra.cpp
+index 21862e6..9f59263 100644
+--- a/Utilities/extra.cpp
++++ b/Utilities/extra.cpp
+@@ -49,7 +49,7 @@ int WriteMatrixMarket_ADOLCInput(string s_postfix, int i_mode, ...) {
+
+ ofstream out_Matrix (s_MatrixName.c_str());
+ if(!out_Matrix) {
+- cout<<"Error creating file: \""<<out_Matrix<<"\""<<endl;
++ cout<<"Error creating file: \""<<s_MatrixName<<"\""<<endl;
+ exit(1);
+ }
+
+@@ -84,7 +84,7 @@ int WriteMatrixMarket_ADOLCInput(string s_postfix, int i_mode, ...) {
+ string s_MatrixName = "pattern"+s_postfix+s_BaseName;
+ ofstream out_Matrix (s_MatrixName.c_str());
+ if(!out_Matrix) {
+- cout<<"Error creating file: \""<<out_Matrix<<"\""<<endl;
++ cout<<"Error creating file: \""<<s_MatrixName<<"\""<<endl;
+ exit(1);
+ }
+
+@@ -111,7 +111,7 @@ int WriteMatrixMarket_ADOLCInput(string s_postfix, int i_mode, ...) {
+ string s_CompressedMatrixName = "CompressedMatrix"+s_postfix+s_BaseName;
+ ofstream out_CompressedMatrix (s_CompressedMatrixName.c_str());
+ if(!out_CompressedMatrix) {
+- cout<<"Error creating file: \""<<out_CompressedMatrix<<"\""<<endl;
++ cout<<"Error creating file: \""<<s_CompressedMatrixName<<"\""<<endl;
+ exit(1);
+ }
+
+@@ -140,7 +140,7 @@ int WriteMatrixMarket_ADOLCInput(string s_postfix, int i_mode, ...) {
+ string s_MatrixName = "pattern_value"+s_postfix+s_BaseName;
+ ofstream out_Matrix (s_MatrixName.c_str());
+ if(!out_Matrix) {
+- cout<<"Error creating file: \""<<out_Matrix<<"\""<<endl;
++ cout<<"Error creating file: \""<<s_MatrixName<<"\""<<endl;
+ exit(1);
+ }
+
+@@ -167,7 +167,7 @@ int WriteMatrixMarket_ADOLCInput(string s_postfix, int i_mode, ...) {
+ string s_CompressedMatrixName = "CompressedMatrix"+s_postfix+s_BaseName;
+ ofstream out_CompressedMatrix (s_CompressedMatrixName.c_str());
+ if(!out_CompressedMatrix) {
+- cout<<"Error creating file: \""<<out_CompressedMatrix<<"\""<<endl;
++ cout<<"Error creating file: \""<<s_CompressedMatrixName<<"\""<<endl;
+ exit(1);
+ }
+
+@@ -671,7 +671,6 @@ int buildDotWithColor(ColPack::GraphColoringInterface &g, vector<string> &ListOf
+ }
+ }
+ }
+-
+ }
+ }
+ }
+@@ -1483,4 +1482,3 @@ int DisplayADICFormat_Value(std::list<std::vector<double> > &lvd_Value) {
+ }
+
+ #endif
+-