summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bettler <thomas.bettler@gmail.com>2022-10-12 16:54:30 +0200
committerSam James <sam@gentoo.org>2022-10-13 00:20:39 +0100
commit455fdcb645d590509ef05f78b012fcaa825d79f8 (patch)
tree03185546bfc24c0359f2f770d378f9c93127840f /sci-libs
parentgnome-extra/cjs: fix MissingUseDepDefault on cairo (diff)
downloadgentoo-455fdcb645d590509ef05f78b012fcaa825d79f8.tar.gz
gentoo-455fdcb645d590509ef05f78b012fcaa825d79f8.tar.bz2
gentoo-455fdcb645d590509ef05f78b012fcaa825d79f8.zip
sci-libs/pdal: bump version 2.4.3
Closes: https://bugs.gentoo.org/873460 Closes: https://github.com/gentoo/gentoo/pull/27751 Signed-off-by: Thomas Bettler <thomas.bettler@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pdal/Manifest1
-rw-r--r--sci-libs/pdal/pdal-2.4.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/pdal/Manifest b/sci-libs/pdal/Manifest
index 7066dee406c7..92734a4b47a1 100644
--- a/sci-libs/pdal/Manifest
+++ b/sci-libs/pdal/Manifest
@@ -1 +1,2 @@
DIST PDAL-2.4.0-src.tar.gz 113449697 BLAKE2B 8f774555d32ad4f0afe6dd850e6dcaf33b58c02934207ee2224230af762a7d3062a48909e267abf790a97a1d11788bb7543971c99239e5ae742d7945db09bda5 SHA512 655fadd2b435ed1cb801ba542028bcc15156da9266eedde93b2210dbadbc50d36b0b6a151062113f2adfb68a2938e2b867438a5a94952a7b3e46f59a53b47623
+DIST PDAL-2.4.3-src.tar.gz 100758279 BLAKE2B 7c157bb51416b24bd8896a62e71a186bc9a45b34d5ab58fadbe691cb1abc9595f598fcf92ec528c9103f646c21f940b26fbf199a998e707d17f1527eb2957a85 SHA512 ed342c29d10c0506e1c0f5ee4dba531189000dd0cc6912f681a95b7c56483d6136e515771a174e20906b1cd81dfd101d53be0cbaf200480d81d053d7dec8a386
diff --git a/sci-libs/pdal/pdal-2.4.3.ebuild b/sci-libs/pdal/pdal-2.4.3.ebuild
new file mode 100644
index 000000000000..9bd82c4dc76e
--- /dev/null
+++ b/sci-libs/pdal/pdal-2.4.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A C++ library for translating and manipulating point cloud data"
+HOMEPAGE="https://pdal.io/"
+SRC_URI="https://github.com/PDAL/PDAL/releases/download/${PV}/PDAL-${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/14"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="
+ net-misc/curl
+ app-arch/zstd:=
+ dev-libs/libxml2
+ dev-libs/openssl:=
+ sci-libs/gdal:=
+ sci-libs/libgeotiff:=
+ sys-libs/libunwind:=
+ sys-libs/zlib
+ postgres? ( dev-db/postgresql:*[xml] )
+"
+DEPEND="
+ test? ( sci-libs/gdal[geos,jpeg,png] )
+ ${RDEPEND}
+"
+
+S="${WORKDIR}/PDAL-${PV}-src"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PLUGIN_PGPOINTCLOUD="$(usex postgres)"
+ -DWITH_COMPLETION=ON
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ --exclude-regex '(pgpointcloudtest|pdal_io_bpf_base_test|pdal_io_bpf_zlib_test|pdal_filters_overlay_test|pdal_filters_stats_test|pdal_app_plugin_test|pdal_merge_test)'
+ --output-on-failure
+ )
+
+ cmake_src_test
+}