summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-02 07:59:39 +0000
committerSam James <sam@gentoo.org>2022-12-02 07:59:43 +0000
commit26f4601c54f33b6eb912dd68a23336d6b1557551 (patch)
treec67b0f5ecb28432ab2bbb1fa324918c3b6a5264a /sci-libs
parentwww-apps/nextcloud: drop 23.0.10, 25.0.0 (diff)
downloadgentoo-26f4601c54f33b6eb912dd68a23336d6b1557551.tar.gz
gentoo-26f4601c54f33b6eb912dd68a23336d6b1557551.tar.bz2
gentoo-26f4601c54f33b6eb912dd68a23336d6b1557551.zip
sci-libs/geos: add 3.11.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/geos-3.11.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index f0ba1c239269..b3cfefdbfa44 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,3 +1,4 @@
DIST geos-3.10.0.tar.bz2 6799370 BLAKE2B dd1490318fccda8ccaf5152f8521ab98ef5e4b143e12e861d02124421985a8b2c966bca6f966aa167fb60f703d25c132b8c7ee4d61e382a449bce5eb40d4cb89 SHA512 12657c6649bfbf6efa3232a054969c6229bb23fc16a7c72d6ca5fdb662e0d08e14bbcaa6944a17de8972b6c236608d94c870ead0b04fada2d2af3d42c238058e
DIST geos-3.10.2.tar.bz2 6714655 BLAKE2B 1bc4f29a28b2b49faa9e1ea2aba7359d6dcb124136e0a2d2069508f7b95fae09e59ecb0acf3742d9261444055e85471cf45baba6e278c8b3501e91eacf3bb886 SHA512 390381711ccf56b862c2736cf6329200822f121de1c49df52b8b85cabea8c7787b199df2196acacc2e5c677ff3ebe042d93d70e89deadbc19d754499edb65126
DIST geos-3.11.0.tar.bz2 6727294 BLAKE2B 7d2cb7ae2dc6c5eb13836c16c8164402c1e964f98df95d5aaf9f6fd957ebcdbdefb43ae4fb17a5a671b6dfdb812bdacfdbfdfdea6e5bd44f135e3701a3cc914d SHA512 40c7553bbb93673c231ddd0131b73bf43b3f50524bc5bd9e6934c068d2c09632f388b7429254ae15d9641da2d15e3a626b430438854e98d9e7419ad04e535189
+DIST geos-3.11.1.tar.bz2 6753232 BLAKE2B 376050ca3224e5220f69d82ff62d79ff7ea3d35d5fe90b7ab4e0cabcb4200b47d7569110538c201df9cb28da784f09f8207a9a8233ee002ab2ec87f5cf336ba1 SHA512 708500aba9b04208ee46a531d55ddf63a213dfaa2922dae937b524300b2b46c95143ed6cd3ff1414e9099f2be95e5df5a2e0b49df43acf93a9478215259f20d3
diff --git a/sci-libs/geos/geos-3.11.1.ebuild b/sci-libs/geos/geos-3.11.1.ebuild
new file mode 100644
index 000000000000..dd84d4906b89
--- /dev/null
+++ b/sci-libs/geos/geos-3.11.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="https://libgeos.org/"
+SRC_URI="https://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ -DUSE_CCACHE=OFF
+
+ # bug #709368
+ $(usex arm '-DDISABLE_GEOS_INLINE=ON' '')
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc ; then
+ HTML_DOCS=( "${BUILD_DIR}"/doxygen/doxygen_docs/html/. )
+ einstalldocs
+ fi
+}