summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-29 09:03:01 +0000
committerSam James <sam@gentoo.org>2021-12-29 09:03:22 +0000
commit5ac778139dcffdf9853020a8938b75e973995896 (patch)
tree5d1f056975cbe12c68660f9b252dda5c8a78cf17 /sci-libs/libdap
parentjava-virtuals/servlet-api: EAPI 8 (diff)
downloadgentoo-5ac778139dcffdf9853020a8938b75e973995896.tar.gz
gentoo-5ac778139dcffdf9853020a8938b75e973995896.tar.bz2
gentoo-5ac778139dcffdf9853020a8938b75e973995896.zip
sci-libs/libdap: add 3.20.9
We were a bit behind in Gentoo so hopefully the linked bug is fixed too. Seems fine for me. Closes: https://bugs.gentoo.org/638494 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/libdap')
-rw-r--r--sci-libs/libdap/Manifest1
-rw-r--r--sci-libs/libdap/files/libdap-3.20.9-disable-net-tests.patch34
-rw-r--r--sci-libs/libdap/libdap-3.20.9.ebuild52
3 files changed, 87 insertions, 0 deletions
diff --git a/sci-libs/libdap/Manifest b/sci-libs/libdap/Manifest
index c134d3de5301..166567f036a9 100644
--- a/sci-libs/libdap/Manifest
+++ b/sci-libs/libdap/Manifest
@@ -1 +1,2 @@
DIST libdap-3.18.1.tar.gz 2209343 BLAKE2B 0b71f5a557315a1481f45b465a73d62e8bf44c78c7b0d257f56c758a63137eca3777a1e2e9ef1e7dc3e2c434709f238fc7ed40e56f61eb89f8d5b47af7504efa SHA512 a1d06bbbad654718bbf9980dc0943935089c09772678f6457d4de8a9d37f1ce33c0e1cab4c5eefec6f9e159028b194d6e3a6021597276b233eda52603ae8dd38
+DIST libdap-3.20.9.tar.gz 2838651 BLAKE2B 84186a73455d8756d0dccaf11554861d48f55a358cc3f70d899d7f24b0b676b0bacdfff47b63c956619717c7fb7f7e3678669599724a2170221a4bc74d8388c2 SHA512 2e360148e5ca3b5c12552ff429b161d8be6905594ae2df98c5b005cd286cb803913b8336371cd07361082749122f7aa5cbc93ff1812ed598908afd0e83df927c
diff --git a/sci-libs/libdap/files/libdap-3.20.9-disable-net-tests.patch b/sci-libs/libdap/files/libdap-3.20.9-disable-net-tests.patch
new file mode 100644
index 000000000000..e4fb53eee3d8
--- /dev/null
+++ b/sci-libs/libdap/files/libdap-3.20.9-disable-net-tests.patch
@@ -0,0 +1,34 @@
+Avoid network test failure:
+```
+## --------------------------------- ##
+## libdap 3.20.9 test suite: getdap. ##
+## --------------------------------- ##
+ 1: getdap -d http://test.opendap.org/dap/data/nc/fnoc1.nc getdap-testsuite/fnoc1.nc.dds (pass) FAILED (getdapTest.at:34)
+
+## ------------- ##
+```
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -43,7 +43,7 @@ endif
+ # TESTS = DASTest DDSTest EXPRTest DMRTest getdapTest
+
+ check_SCRIPTS = $(DASTESTSUITE) $(DDSTESTSUITE) $(EXPRTESTSUITE) \
+- $(DMRTESTSUITE) $(GETDAPTESTSUITE)
++ $(DMRTESTSUITE)
+
+ # Build the test drivers. The drivers all use the
+ # subclassed types in Test*.cc and the TestTypesFactory.
+@@ -117,12 +117,11 @@ DMRTESTSUITE = $(srcdir)/DMRTest
+ GETDAPTESTSUITE = $(srcdir)/getdapTest
+
+ check-local: atconfig atlocal $(DASTESTSUITE) $(DDSTESTSUITE) \
+-$(EXPRTESTSUITE) $(DMRTESTSUITE) $(GETDAPTESTSUITE)
++$(EXPRTESTSUITE) $(DMRTESTSUITE)
+ $(SHELL) '$(DASTESTSUITE)' $(TESTSUITEFLAGS)
+ $(SHELL) '$(DDSTESTSUITE)' $(TESTSUITEFLAGS)
+ $(SHELL) '$(EXPRTESTSUITE)' $(TESTSUITEFLAGS)
+ $(SHELL) '$(DMRTESTSUITE)' $(TESTSUITEFLAGS)
+- $(SHELL) '$(GETDAPTESTSUITE)' $(TESTSUITEFLAGS)
+
+ # Make sure there are no spaces after the DASTESTSUITE names. jhrg 3/16/15
+ # Delete the scripts here and not using CLEANFILES because this target is
diff --git a/sci-libs/libdap/libdap-3.20.9.ebuild b/sci-libs/libdap/libdap-3.20.9.ebuild
new file mode 100644
index 000000000000..7e2276b04adb
--- /dev/null
+++ b/sci-libs/libdap/libdap-3.20.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Implementation of a C++ SDK for DAP 2.0 and 3.2"
+HOMEPAGE="https://www.opendap.org"
+SRC_URI="https://www.opendap.org/pub/source/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 URI )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/flex
+ test? ( dev-util/cppunit )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.20.9-disable-net-tests.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # bug 619144
+ append-cxxflags -std=c++14
+
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # package provides .pc files
+ find "${ED}" -name '*.la' -delete || die
+}