summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2017-06-25 17:06:35 -0700
committerMichał Górny <mgorny@gentoo.org>2017-07-11 22:01:20 +0200
commit8cbaa392c59f6ad8429d420e3aca553218f65e50 (patch)
tree41916d9bb87669c99b48a83b7bc8b5e9d0e6dea3 /sci-electronics/kicad
parentsci-electronics/kicad: Fix configure issue w/ USE='-python', #620130 (diff)
downloadgentoo-8cbaa392c59f6ad8429d420e3aca553218f65e50.tar.gz
gentoo-8cbaa392c59f6ad8429d420e3aca553218f65e50.tar.bz2
gentoo-8cbaa392c59f6ad8429d420e3aca553218f65e50.zip
sci-electronics/kicad: Fix desktop file categories, #622052
Closes: https://github.com/gentoo/gentoo/pull/4990 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-electronics/kicad')
-rw-r--r--sci-electronics/kicad/kicad-4.0.5-r1.ebuild9
-rw-r--r--sci-electronics/kicad/kicad-4.0.6.ebuild9
2 files changed, 10 insertions, 8 deletions
diff --git a/sci-electronics/kicad/kicad-4.0.5-r1.ebuild b/sci-electronics/kicad/kicad-4.0.5-r1.ebuild
index 85d80609cb07..da56b49911ba 100644
--- a/sci-electronics/kicad/kicad-4.0.5-r1.ebuild
+++ b/sci-electronics/kicad/kicad-4.0.5-r1.ebuild
@@ -66,14 +66,15 @@ src_prepare() {
# Patch to work with >=boost 1.61
eapply "${FILESDIR}/${PN}-boost-1.61.patch"
- # remove all the non unix file endings
+ # Remove cvpcb desktop file as it does nothing
+ rm "resources/linux/mime/applications/cvpcb.desktop" || die
+
+ # remove all the non unix file endings and fix application categories in desktop files
while IFS="" read -d $'\0' -r f; do
edos2unix "${f}"
+ sed -i '/Categories/s/Development;//' "${f}"
done < <(find "${S}" -type f -name "*.desktop" -print0)
- # Remove cvpcb desktop file while it does nothing
- rm "${WORKDIR}/${P}/resources/linux/mime/applications/cvpcb.desktop" || die
-
# Handle optional minimal install.
if use minimal; then
# remove templates as they are not needed to run binaries
diff --git a/sci-electronics/kicad/kicad-4.0.6.ebuild b/sci-electronics/kicad/kicad-4.0.6.ebuild
index 85d80609cb07..da56b49911ba 100644
--- a/sci-electronics/kicad/kicad-4.0.6.ebuild
+++ b/sci-electronics/kicad/kicad-4.0.6.ebuild
@@ -66,14 +66,15 @@ src_prepare() {
# Patch to work with >=boost 1.61
eapply "${FILESDIR}/${PN}-boost-1.61.patch"
- # remove all the non unix file endings
+ # Remove cvpcb desktop file as it does nothing
+ rm "resources/linux/mime/applications/cvpcb.desktop" || die
+
+ # remove all the non unix file endings and fix application categories in desktop files
while IFS="" read -d $'\0' -r f; do
edos2unix "${f}"
+ sed -i '/Categories/s/Development;//' "${f}"
done < <(find "${S}" -type f -name "*.desktop" -print0)
- # Remove cvpcb desktop file while it does nothing
- rm "${WORKDIR}/${P}/resources/linux/mime/applications/cvpcb.desktop" || die
-
# Handle optional minimal install.
if use minimal; then
# remove templates as they are not needed to run binaries