summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2023-03-19 10:13:38 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2023-03-19 10:15:17 -0700
commit6f38c950345b755b43f988ef0e6300311a73273e (patch)
tree919435471099d0940963bf69d8e96d90e9e2b15f /net-misc
parentpackage.mask: Last rite sci-libs/xdrfile (diff)
downloadgentoo-6f38c950345b755b43f988ef0e6300311a73273e.tar.gz
gentoo-6f38c950345b755b43f988ef0e6300311a73273e.tar.bz2
gentoo-6f38c950345b755b43f988ef0e6300311a73273e.zip
net-misc/s4cmd: tweak to support newer botocore automatically
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/s4cmd/Manifest1
-rw-r--r--net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/s4cmd/Manifest b/net-misc/s4cmd/Manifest
index b9594713d437..2f1d3e2af092 100644
--- a/net-misc/s4cmd/Manifest
+++ b/net-misc/s4cmd/Manifest
@@ -1 +1,2 @@
+DIST s4cmd-2.1.0-botocore-fix.patch 2449 BLAKE2B 5158ded38f8e3417c090d274063a4eaa4f25cd5005c4bb8793cc639d3d87875f31d87464a8dbb44b5c1690570865cb01a0681f2e92edc46fa549828b91f30a0a SHA512 ea889d069a86a1d1f7f5cf5b1f19a9d0b35527c3db5eecf9202cca742ad4442655169d8688fc4b290a1362a0a794ba8ac44abf697ea7830acf8e48b6c7998ef6
DIST s4cmd-2.1.0.tar.gz 39312 BLAKE2B 9d2d533273543153f2bad69362933315f65c5e70bd45c102e42b1b733989815239ae4d027ac08d658f03263bd9dd75f1f6db802b5f38ed3256da5e7c9f48558c SHA512 05e930e2789ce8ab280dcdb2f08e4162930d946d2ed2e4f1c754c8b875375774779b73729151bd23d9bf3736bc48f7626fe53df66aff71dd11b32e90e9355470
diff --git a/net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild b/net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..6be09aed0ddd
--- /dev/null
+++ b/net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 bash-completion-r1
+
+DESCRIPTION="Super S3 command line tool"
+HOMEPAGE="https://github.com/bloomreach/s4cmd"
+SRC_URI="https://github.com/bloomreach/s4cmd/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://github.com/bloomreach/s4cmd/pull/310.patch -> ${P}-botocore-fix.patch "
+PATCHES=(
+ "${DISTDIR}/${P}-botocore-fix.patch"
+)
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_install() {
+ distutils-r1_src_install
+ dobashcomp data/bash-completion/s4cmd
+ rm -f "${D}"/usr/bin/s4cmd.py
+}