summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-04 09:02:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-04 09:17:28 +0100
commit6ac543af08bf7f83f28921d1cad72f69e3fd0ff4 (patch)
treedd14cbfb73ed2c5c60e89ed0f8352ef46454f3af /net-misc
parentapp-editors/mg: x86 stable wrt bug #768522 (diff)
downloadgentoo-6ac543af08bf7f83f28921d1cad72f69e3fd0ff4.tar.gz
gentoo-6ac543af08bf7f83f28921d1cad72f69e3fd0ff4.tar.bz2
gentoo-6ac543af08bf7f83f28921d1cad72f69e3fd0ff4.zip
net-misc/youtube-dl: Bump to 2021.02.04.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2021.02.04.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 0fd3e943eee7..5134c9544ad4 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2021.01.16.tar.gz 3275243 BLAKE2B 970bfff5db0aca7e386027e20f2b4d7e6b7209037820f3e0960f2e19b3b8e0aaf0f62bacb1794a15f359108533cbc396dddea99c84a8c88c13891329d2685326 SHA512 01b73f2e626df69249057ddc205d49dc7d6d16c66f4349fcdde5990615d1d13e0b5db15d65fb35e0c1328f7dc67d1473183228778614ccb7a3c9d27e80a0a38d
DIST youtube-dl-2021.01.24.1.tar.gz 3288395 BLAKE2B f0adc4ed7627cfda3b7729afd0e4617c1d78b44b5cb84186251eacdfb54bdd0ad2395253899a1aed1ba708856e872ca0537baf316f08b289140bdacb3976e9d6 SHA512 b5ab1e03f38b5628487fdfa22febd594f87d42c228fcc0b03966205ca3fbc6fa6103388f8736ad22e7d517359823d8ca6cc61aeb80fdd69db06a82d55437bacb
+DIST youtube-dl-2021.02.04.1.tar.gz 3274333 BLAKE2B 46f5c332f7346db589cd6d5c0fe649b547e948903f90851d6ead0322ec516300dd65189d781ffd24711336dc1f310920a4c5a6f9d6a1944046e900bcd22ee675 SHA512 b1050ace3adf1811adaa336d5b3574c938bf6fde1163e50b35c8a11bb5c251cf272ca5de3ff8132a44417ea2ced7b611c19e4aaf4dfd12adfeac03afe14df0dc
DIST youtube-dl-2021.02.04.tar.gz 3274222 BLAKE2B 6ec6b4031b8fff7630bbbebcef5795962d7bc6c12a04799f0a04d8b14023e651a06757f918dc6d3c3b6833b7662c742c26dbe68e3f1a35159c0dda49ef6c2f32 SHA512 44dab7016d625235aab244161bfcc959d6fd22cb176ca0fb59f60eb31229da343f0a40c162c37a7e829bfa82fed541b66266d28cd859fc18a78bb1936f3fde22
diff --git a/net-misc/youtube-dl/youtube-dl-2021.02.04.1.ebuild b/net-misc/youtube-dl/youtube-dl-2021.02.04.1.ebuild
new file mode 100644
index 000000000000..9b024e43dbba
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2021.02.04.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman youtube-dl.1
+
+ newbashcomp youtube-dl.bash-completion youtube-dl
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "youtube-dl works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. youtube-dl will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want youtube-dl to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}