summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-13 21:57:22 -0400
committerSam James <sam@gentoo.org>2024-03-14 01:59:52 +0000
commit23d034269b1fcfe85d736ef3131820a8b5fe789e (patch)
tree710946e16e9aa4ae4a92d7b59f87b06aa098349f /net-misc/portspoof
parentnet-misc/portspoof: run the full default src_prepare (diff)
downloadgentoo-23d034269b1fcfe85d736ef3131820a8b5fe789e.tar.gz
gentoo-23d034269b1fcfe85d736ef3131820a8b5fe789e.tar.bz2
gentoo-23d034269b1fcfe85d736ef3131820a8b5fe789e.zip
net-misc/portspoof: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/861698 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/portspoof')
-rw-r--r--net-misc/portspoof/portspoof-1.3-r1.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/net-misc/portspoof/portspoof-1.3-r1.ebuild b/net-misc/portspoof/portspoof-1.3-r1.ebuild
index ad443ee320fb..d0fed28eeb2b 100644
--- a/net-misc/portspoof/portspoof-1.3-r1.ebuild
+++ b/net-misc/portspoof/portspoof-1.3-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="return SYN+ACK for every port connection attempt"
HOMEPAGE="http://portspoof.org/"
LICENSE="GPL-2+"
@@ -29,6 +31,18 @@ src_prepare() {
sed -i '/#include <sys\/sysctl.h>/d' src/connection.h || die
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861698
+ # https://github.com/drk1wi/portspoof/issues/48
+ #
+ # Do not trust it with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default_src_install
newsbin system_files/init.d/portspoof.sh portspoof-runner