summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-07-03 09:34:00 +0700
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-07-03 09:36:00 +0700
commitad4a8aa185ee5c83bb775f398b93da9faf4431c6 (patch)
tree85987ca73bec217aa2a6bdfe8dab96a0ab26a75f /net-misc/curl
parentsys-devel/gcc: add 10.5.9999, drop 10.4.9999 (diff)
downloadgentoo-ad4a8aa185ee5c83bb775f398b93da9faf4431c6.tar.gz
gentoo-ad4a8aa185ee5c83bb775f398b93da9faf4431c6.tar.bz2
gentoo-ad4a8aa185ee5c83bb775f398b93da9faf4431c6.zip
net-misc/curl: Add build fix for e.g. gcc-12/riscv
Patch comes from upstream master Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/curl-7.84.0.ebuild1
-rw-r--r--net-misc/curl/files/curl-7.84.0-easylock.patch30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/curl/curl-7.84.0.ebuild b/net-misc/curl/curl-7.84.0.ebuild
index c55c9520aa81..645a223aed8f 100644
--- a/net-misc/curl/curl-7.84.0.ebuild
+++ b/net-misc/curl/curl-7.84.0.ebuild
@@ -95,6 +95,7 @@ MULTILIB_CHOST_TOOLS=(
PATCHES=(
"${FILESDIR}"/${PN}-7.30.0-prefix.patch
+ "${FILESDIR}"/${PN}-7.84.0-easylock.patch
"${FILESDIR}"/${PN}-respect-cflags-3.patch
"${FILESDIR}"/${PN}-7.84.0-include-sched.patch
)
diff --git a/net-misc/curl/files/curl-7.84.0-easylock.patch b/net-misc/curl/files/curl-7.84.0-easylock.patch
new file mode 100644
index 000000000000..77ee610fc117
--- /dev/null
+++ b/net-misc/curl/files/curl-7.84.0-easylock.patch
@@ -0,0 +1,30 @@
+From 50efb0822aa0e0ab165158dd0a26e65a2290e6d2 Mon Sep 17 00:00:00 2001
+From: Daniel Stenberg <daniel@haxx.se>
+Date: Tue, 28 Jun 2022 09:00:25 +0200
+Subject: [PATCH] easy_lock: switch to using atomic_int instead of bool
+
+To work with more compilers without requiring separate libs to
+link. Like with gcc-12 for RISC-V on Linux.
+
+Reported-by: Adam Sampson
+Fixes #9055
+Closes #9061
+---
+ lib/easy_lock.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lib/easy_lock.h b/lib/easy_lock.h
+index 07c85c5ffdd19..9c11bc50c5f20 100644
+--- a/lib/easy_lock.h
++++ b/lib/easy_lock.h
+@@ -40,8 +40,8 @@
+ #include <sched.h>
+ #endif
+
+-#define curl_simple_lock atomic_bool
+-#define CURL_SIMPLE_LOCK_INIT false
++#define curl_simple_lock atomic_int
++#define CURL_SIMPLE_LOCK_INIT 0
+
+ static inline void curl_simple_lock_lock(curl_simple_lock *lock)
+ {