summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/uw-mailutils/uw-mailutils-2007f.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/uw-mailutils/uw-mailutils-2007f.ebuild')
-rw-r--r--net-mail/uw-mailutils/uw-mailutils-2007f.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-mail/uw-mailutils/uw-mailutils-2007f.ebuild b/net-mail/uw-mailutils/uw-mailutils-2007f.ebuild
new file mode 100644
index 000000000000..63b3941c97c1
--- /dev/null
+++ b/net-mail/uw-mailutils/uw-mailutils-2007f.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils flag-o-matic
+
+MY_P="imap-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Mail utilities from the UW"
+HOMEPAGE="http://www.washington.edu/imap/"
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="pam ssl"
+
+DEPEND="pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ !<net-mail/uw-imap-${PV}"
+
+src_prepare() {
+ chmod -R ug+w "${S}"
+
+ epatch "${FILESDIR}/${PN}-2004g.patch"
+ epatch "${FILESDIR}/${PN}-ssl.patch"
+
+ # no interactive build
+ sed -i -e "/read x; case/s/^/#/" Makefile || die
+
+ sed -i -e "s|\`cat \$C/CFLAGS\`|${CFLAGS}|g" \
+ src/mailutil/Makefile \
+ src/mtest/Makefile || die "sed failed patching Makefile CFLAGS."
+
+ append-flags -fPIC
+}
+
+src_compile() {
+ local port=slx
+ use elibc_FreeBSD && port=bsf
+ use pam && port=lnp
+ local ssltype=none
+ use ssl && ssltype=nopwd
+ emake -j1 "${port}" EXTRACFLAGS="${CFLAGS}" EXTRALDFLAGS="${LDFLAGS}" SSLTYPE="${ssltype}"
+}
+
+src_install() {
+ dobin mailutil/mailutil mtest/mtest
+ doman src/mailutil/mailutil.1
+}