summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-01-24 18:59:19 +0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-02-06 16:32:26 -0800
commit3492a67e828d7c5661dd66d48fbb628609f3b966 (patch)
tree1f4b0f1262c2fbd5823989f6c6488c9d719259ae /net-libs
parentnet-im/telegram-desktop: remove unused patches (diff)
downloadgentoo-3492a67e828d7c5661dd66d48fbb628609f3b966.tar.gz
gentoo-3492a67e828d7c5661dd66d48fbb628609f3b966.tar.bz2
gentoo-3492a67e828d7c5661dd66d48fbb628609f3b966.zip
net-libs/grpc: add 1.51.1
- bump to EAPI=8 - bump dev-cpp/abseil-cpp to 0/20220623 subslot, fixing compatibility with e.g. >=app-office/libreoffice-bin-7.4 - suppress the package's attempt to fetch submodule content Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/29242 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/grpc/Manifest1
-rw-r--r--net-libs/grpc/grpc-1.51.1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/net-libs/grpc/Manifest b/net-libs/grpc/Manifest
index b794e03563d0..0c26fe648981 100644
--- a/net-libs/grpc/Manifest
+++ b/net-libs/grpc/Manifest
@@ -1 +1,2 @@
DIST grpc-1.43.0.tar.gz 8540919 BLAKE2B dc78026129a5d23e864c92a210e8de845a4bad886071a76d527730108da155d290612f1e54cec15d69f55713f37f377e6bff844b16b5deef64c7d8bb31195652 SHA512 e0471aa355d311a40c9d29d7101bf8e22b89ac675d4914c38e617d3213b61107487ef20ca80d7cff8093b548f4a976526298e1f32959ae6ce3c088d45ecc9781
+DIST grpc-1.51.1.tar.gz 8550112 BLAKE2B 83ba622222e941a6a0fa33f4878e9a10f4165d29ade36fb58201bc76dad9b075d1cc5474c2a8e48f63b63a7b2d0e169f58af88fff837973ae03315833f2c2eb7 SHA512 1bc8e7a5a15b2dca88527d111cde398b0dc1921bbc945c6df8225b4225b8ac0b43155bcf743230ce7b5962d1ab948e9363229c98a879b1befc7a939a290fb888
diff --git a/net-libs/grpc/grpc-1.51.1.ebuild b/net-libs/grpc/grpc-1.51.1.ebuild
new file mode 100644
index 000000000000..f3edebd3268c
--- /dev/null
+++ b/net-libs/grpc/grpc-1.51.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PV="${PV//_pre/-pre}"
+
+DESCRIPTION="Modern open source high performance RPC framework"
+HOMEPAGE="https://www.grpc.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+# format is 0/${CORE_SOVERSION//./}.${CPP_SOVERSION//./} , check top level CMakeLists.txt
+SLOT="0/29.151"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc examples test"
+
+# look for submodule versions in third_party dir
+RDEPEND="
+ =dev-cpp/abseil-cpp-20220623.1*:=
+ >=dev-libs/re2-0.2021.11.01:=
+ >=dev-libs/openssl-1.1.1:0=[-bindist(-)]
+ >=dev-libs/protobuf-3.18.1:=
+ dev-libs/xxhash
+ >=net-dns/c-ares-1.15.0:=
+ sys-libs/zlib:=
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/benchmark
+ dev-cpp/gflags
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+# requires sources of many google tools
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+soversion_check() {
+ local core_sover cpp_sover
+ # extract quoted number. line we check looks like this: 'set(gRPC_CPP_SOVERSION "1.37")'
+ core_sover="$(grep 'set(gRPC_CORE_SOVERSION ' CMakeLists.txt | sed '/.*\"\(.*\)\".*/ s//\1/')"
+ cpp_sover="$(grep 'set(gRPC_CPP_SOVERSION ' CMakeLists.txt | sed '/.*\"\(.*\)\".*/ s//\1/')"
+ # remove dots, e.g. 1.37 -> 137
+ core_sover="${core_sover//./}"
+ cpp_sover="${cpp_sover//./}"
+ [[ ${core_sover} -eq $(ver_cut 2 ${SLOT}) ]] || die "fix core sublot! should be ${core_sover}"
+ [[ ${cpp_sover} -eq $(ver_cut 3 ${SLOT}) ]] || die "fix cpp sublot! should be ${cpp_sover}"
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # un-hardcode libdir
+ sed -i "s@/lib@/$(get_libdir)@" cmake/pkg-config-template.pc.in || die
+
+ # suppress network access, package builds fine without the submodules
+ mkdir "${S}/third_party/opencensus-proto/src" || die
+
+ soversion_check
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DgRPC_INSTALL=ON
+ -DgRPC_ABSL_PROVIDER=package
+ -DgRPC_BACKWARDS_COMPATIBILITY_MODE=OFF
+ -DgRPC_CARES_PROVIDER=package
+ -DgRPC_INSTALL_CMAKEDIR="$(get_libdir)/cmake/${PN}"
+ -DgRPC_INSTALL_LIBDIR="$(get_libdir)"
+ -DgRPC_PROTOBUF_PROVIDER=package
+ -DgRPC_RE2_PROVIDER=package
+ -DgRPC_SSL_PROVIDER=package
+ -DgRPC_ZLIB_PROVIDER=package
+ -DgRPC_BUILD_TESTS=$(usex test)
+ -DCMAKE_CXX_STANDARD=17
+ $(usex test '-DgRPC_BENCHMARK_PROVIDER=package' '')
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use examples; then
+ find examples -name '.gitignore' -delete || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ if use doc; then
+ find doc -name '.gitignore' -delete || die
+ local DOCS=( AUTHORS CONCEPTS.md README.md TROUBLESHOOTING.md doc/. )
+ fi
+
+ einstalldocs
+}