summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 21:01:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:24 +0100
commit31e21551da418ddc7a177c7c869070e9acca817c (patch)
tree0ad1bfcfc7068989bcb92c3f4499f5a84cfd8c95 /net-libs/ngtcp2
parent*/*: Switch games proj to cmake.eclass (diff)
downloadgentoo-31e21551da418ddc7a177c7c869070e9acca817c.tar.gz
gentoo-31e21551da418ddc7a177c7c869070e9acca817c.tar.bz2
gentoo-31e21551da418ddc7a177c7c869070e9acca817c.zip
*/*: Switch candrews' packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/ngtcp2')
-rw-r--r--net-libs/ngtcp2/ngtcp2-0_pre20190912.ebuild5
-rw-r--r--net-libs/ngtcp2/ngtcp2-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/net-libs/ngtcp2/ngtcp2-0_pre20190912.ebuild b/net-libs/ngtcp2/ngtcp2-0_pre20190912.ebuild
index 044390610304..b5cafbd8d8df 100644
--- a/net-libs/ngtcp2/ngtcp2-0_pre20190912.ebuild
+++ b/net-libs/ngtcp2/ngtcp2-0_pre20190912.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == 9999 ]] ; then
@@ -35,9 +36,9 @@ multilib_src_configure() {
-DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
-DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {
- cmake-utils_src_make check
+ cmake_build check
}
diff --git a/net-libs/ngtcp2/ngtcp2-9999.ebuild b/net-libs/ngtcp2/ngtcp2-9999.ebuild
index 43db6bf28c55..8031a8e7028a 100644
--- a/net-libs/ngtcp2/ngtcp2-9999.ebuild
+++ b/net-libs/ngtcp2/ngtcp2-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == 9999 ]] ; then
@@ -33,9 +34,9 @@ multilib_src_configure() {
-DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
-DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {
- cmake-utils_src_make check
+ cmake_build check
}