summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-12 10:58:28 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-12 11:03:22 +0100
commite65198b472ba87256e659e1f35563dba622b3478 (patch)
tree5188b6397278fafdcea0df7951f54f437344b466 /net-libs/libnetconf2
parentnet-libs/libyang: add 2.0.112 (diff)
downloadgentoo-e65198b472ba87256e659e1f35563dba622b3478.tar.gz
gentoo-e65198b472ba87256e659e1f35563dba622b3478.tar.bz2
gentoo-e65198b472ba87256e659e1f35563dba622b3478.zip
net-libs/libnetconf2: add 2.0.24
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-libs/libnetconf2')
-rw-r--r--net-libs/libnetconf2/Manifest1
-rw-r--r--net-libs/libnetconf2/libnetconf2-2.0.24.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/libnetconf2/Manifest b/net-libs/libnetconf2/Manifest
index d48de67fcdc3..3b2bbaf918f4 100644
--- a/net-libs/libnetconf2/Manifest
+++ b/net-libs/libnetconf2/Manifest
@@ -1 +1,2 @@
DIST libnetconf2-2.0.19.tar.gz 300454 BLAKE2B 7ff97dcc964124f93631b2fe08f9f713deb698e7d591ca245f9638f32a19915ce6e8cf9e7170bcd6059369926044a705fc03ef18e28baba8eef1c8296bb52d8e SHA512 0e53d4803b8a5d3ff041b393487c71ca09878fa47cbe3ac4d1f26cf45f2ede80992964e339747435003c3bc61053f4b6297a29d6e2a5511ba6b4e93edb3ce136
+DIST libnetconf2-2.0.24.tar.gz 301111 BLAKE2B ffc4dffd797e4589a5892f3cf80d6a373808ee48c00e46a37ff02082c721c49b27aa06962e962698d3b443e08e9cba55b4205cc6e76958df325c6fc5a38fed22 SHA512 05cba691bc47e49abf747a36a6dcc978a4163fd155a90609315585201e4e4d20c9a30b683180f5cf03aac5b6a37933917e61a895067dd172b8de2142ec542dfc
diff --git a/net-libs/libnetconf2/libnetconf2-2.0.24.ebuild b/net-libs/libnetconf2/libnetconf2-2.0.24.ebuild
new file mode 100644
index 000000000000..831ee0c2cca4
--- /dev/null
+++ b/net-libs/libnetconf2/libnetconf2-2.0.24.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C library for building NETCONF servers and clients"
+HOMEPAGE="https://github.com/CESNET/libnetconf2"
+SRC_URI="https://github.com/CESNET/libnetconf2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ >=net-libs/libyang-2.0.112:=
+ net-libs/libssh:0=[server]
+ virtual/libcrypt:="
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VALGRIND_TESTS=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r doc/.
+}