summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/gupnp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/gupnp')
-rw-r--r--net-libs/gupnp/Manifest2
-rw-r--r--net-libs/gupnp/gupnp-0.20.13.ebuild76
-rw-r--r--net-libs/gupnp/gupnp-0.20.14.ebuild77
-rw-r--r--net-libs/gupnp/metadata.xml5
4 files changed, 160 insertions, 0 deletions
diff --git a/net-libs/gupnp/Manifest b/net-libs/gupnp/Manifest
new file mode 100644
index 000000000000..e0abbeae75db
--- /dev/null
+++ b/net-libs/gupnp/Manifest
@@ -0,0 +1,2 @@
+DIST gupnp-0.20.13.tar.xz 395356 SHA256 d779b094f13097a5900689b3587e5b495d79112d0855ed842577acba25c902b3 SHA512 dfc73a50f93dba84042652556a3fad870137fda3659fac4fe735c3d2cecf94d6908382d88cf85122840dd61017b9348f97edb6ded6d876d5e35058d70f9b8dc1 WHIRLPOOL 5d3cb3f9411324d73d33728e137c7b75c16386a5c57470c5213c3393582b6ebdd9889d6e5cc702128bb1c0f8514958b3bf70607cbd38dfe957b11bd03dda3009
+DIST gupnp-0.20.14.tar.xz 396764 SHA256 77ffb940ba77c4a6426d09d41004c75d92652dcbde86c84ac1c847dbd9ad59bd SHA512 56d0ee6c2ef8a3c82c61793cf2ce81cd0dd86a0975c1366678337f80178e64f473fbe985e41f7e04225b150edf44e74a9ff96fe687d5710ab90f0b033750edf4 WHIRLPOOL b7de86ff4e364f775699932669dc6c58cb25cde1b8825de72243dc04828400a685c21a12d43a7a36aa1c2cfe64089c47c9ca9298f174a09ba17dcdf75422c809
diff --git a/net-libs/gupnp/gupnp-0.20.13.ebuild b/net-libs/gupnp/gupnp-0.20.13.ebuild
new file mode 100644
index 000000000000..b4a0b6d68550
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.20.13.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+# FIXME: Claims to works with python3 but appears to be wishful thinking
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 multilib-minimal python-r1 vala
+
+DESCRIPTION="An object-oriented framework for creating UPnP devs and control points"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ppc64 ~sparc x86"
+IUSE="connman +introspection kernel_linux networkmanager"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( connman networkmanager )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=net-libs/gssdp-0.14.7:0=[introspection?,${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.48.0:2.4[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+ || (
+ >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}]
+ <sys-libs/e2fsprogs-libs-1.41.8[${MULTILIB_USEDEP}] )
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.4
+ $(vala_depend) )
+ connman? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ networkmanager? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1
+ sys-devel/gettext
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local backend=unix
+ use kernel_linux && backend=linux
+ use connman && backend=connman
+ use networkmanager && backend=network-manager
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ --disable-static \
+ --with-context-manager=${backend}
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ python_parallel_foreach_impl python_doscript tools/gupnp-binding-tool
+}
diff --git a/net-libs/gupnp/gupnp-0.20.14.ebuild b/net-libs/gupnp/gupnp-0.20.14.ebuild
new file mode 100644
index 000000000000..364f6f1a263e
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.20.14.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+# FIXME: Claims to works with python3 but appears to be wishful thinking
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 multilib-minimal python-r1 vala
+
+DESCRIPTION="An object-oriented framework for creating UPnP devs and control points"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="connman +introspection kernel_linux networkmanager"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( connman networkmanager )"
+
+# prefix: uuid dependency can be adapted to non-linux platforms
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=net-libs/gssdp-0.14.7:0=[introspection?,${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.48.0:2.4[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+ || (
+ >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}]
+ <sys-libs/e2fsprogs-libs-1.41.8[${MULTILIB_USEDEP}] )
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.4
+ $(vala_depend) )
+ connman? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ networkmanager? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1
+ sys-devel/gettext
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local backend=unix
+ use kernel_linux && backend=linux
+ use connman && backend=connman
+ use networkmanager && backend=network-manager
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ --disable-static \
+ --with-context-manager=${backend}
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ python_parallel_foreach_impl python_doscript tools/gupnp-binding-tool
+}
diff --git a/net-libs/gupnp/metadata.xml b/net-libs/gupnp/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-libs/gupnp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>