summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jaeger <pascal.jaeger@leimstift.de>2022-09-26 15:13:25 +0200
committerMatt Turner <mattst88@gentoo.org>2022-10-06 19:11:16 -0400
commit31c73b13ec260966521c7a60b66414353482b8d7 (patch)
treef89d14db10820b1765118a4ae14baa1f32b14693 /net-libs/gnome-online-accounts
parentdev-lang/rust: backport is_libcxx_linked to older versions (diff)
downloadgentoo-31c73b13ec260966521c7a60b66414353482b8d7.tar.gz
gentoo-31c73b13ec260966521c7a60b66414353482b8d7.tar.bz2
gentoo-31c73b13ec260966521c7a60b66414353482b8d7.zip
net-libs/gnome-online-accounts: Version bump to 3.46.0
Closes: https://github.com/gentoo/gentoo/pull/27473 Signed-off-by: Pascal Jaeger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/Manifest1
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index 3e344010e831..5933870f9b1c 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1 +1,2 @@
DIST gnome-online-accounts-3.44.0.tar.xz 859564 BLAKE2B 6131094df19d5f282491bd19a97f6e0248b10a5c4db19962a6804523101fb86d6bed7523b46cef91328e0f3c7b6496068594de0689ab1fcb63fd8fb80eece49c SHA512 e70a83b557b816dc7eb22bcd1e4a263044a16c981dfa945a529250ea76e743c9cc73f2ecd4f3006d28a4f3161c7a15dba8bd1416b413c28f4d86d0192755e809
+DIST gnome-online-accounts-3.46.0.tar.xz 379464 BLAKE2B 20825f2836e334d3f26222ae0583a7dd27d00528fa0e0a1b67f940ada633e3bd3ec93b251f40c88a850ade7dbe503b9610cd4f982eece368a61c04d0d54181f7 SHA512 727eaf248d70ba8b3874ca500d40e6fead3f76f72aee1b1f383aac57ee71bdb77dab7da3487b3f0fee665130cc61ac8b53f3a1bf1754e5df919fc5c48486c201
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild
new file mode 100644
index 000000000000..cf7e18995da4
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="debug gnome gtk-doc +introspection kerberos man +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.67.4:2
+ sys-apps/dbus
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ >=x11-libs/gtk+-3.19.12:3
+ >=net-libs/webkit-gtk-2.33.1:4.1
+ >=dev-libs/json-glib-0.16
+ >=app-crypt/libsecret-0.5
+ >=net-libs/libsoup-3.0:3.0
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.0:1.0
+ kerberos? (
+ app-crypt/gcr:0=[gtk]
+ app-crypt/mit-krb5
+ )
+"
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.30.0
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+BDEPEND="gtk-doc? ( dev-util/gtk-doc )"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ local emesonargs=(
+ -Dgoabackend=true
+ -Dinspector=false
+ -Dexchange=true
+ -Dfedora=false
+ -Dgoogle=true
+ -Dimap_smtp=true
+ $(meson_use kerberos)
+ -Dlastfm=true
+ -Dmedia_server=true
+ -Downcloud=true
+ -Dwindows_live=true
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ -Dman=true
+ $(meson use vala vapi)
+ )
+ meson_src_configure
+}