summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Udvare <audvare@gmail.com>2024-05-03 03:57:46 -0400
committerSam James <sam@gentoo.org>2024-07-23 06:29:54 +0100
commitb7a5322ca6893e2388e0a50dae5df71282ce26f4 (patch)
tree529fd944e811f77fd3af07a18362cd2541bdc050 /net-irc
parentdev-ruby/liquid: drop 5.4.0 (diff)
downloadgentoo-b7a5322ca6893e2388e0a50dae5df71282ce26f4.tar.gz
gentoo-b7a5322ca6893e2388e0a50dae5df71282ce26f4.tar.bz2
gentoo-b7a5322ca6893e2388e0a50dae5df71282ce26f4.zip
net-irc/quassel: add patch to fix /exec scriptname
From https://github.com/quassel/quassel/pull/609 Signed-off-by: Andrew Udvare <audvare@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/files/quassel-0.14.0-fix-exec-script.patch29
-rw-r--r--net-irc/quassel/quassel-0.14.0-r2.ebuild3
2 files changed, 31 insertions, 1 deletions
diff --git a/net-irc/quassel/files/quassel-0.14.0-fix-exec-script.patch b/net-irc/quassel/files/quassel-0.14.0-fix-exec-script.patch
new file mode 100644
index 000000000000..fcaa188effcb
--- /dev/null
+++ b/net-irc/quassel/files/quassel-0.14.0-fix-exec-script.patch
@@ -0,0 +1,29 @@
+From 247d7fe0a99a4e2a1c1b861455062c5630428492 Mon Sep 17 00:00:00 2001
+From: Max Audron <audron@cocaine.farm>
+Date: Tue, 18 Oct 2022 15:04:17 +0200
+Subject: [PATCH] fix client execwrapper not using full path to script
+
+The clients execwrapper was using the scriptName instead of the full
+path fileName to execute scripts leading to scripts only being found and
+executed if the script directory was also in $PATH or a executable with
+the same name as the script was in $PATH.
+
+This could also lead to confusion as it executes whatever is in $PATH
+instead of the actual script in quassels directories.
+---
+ src/client/execwrapper.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/client/execwrapper.cpp b/src/client/execwrapper.cpp
+index 5cbecf675..6ec519c4d 100644
+--- a/src/client/execwrapper.cpp
++++ b/src/client/execwrapper.cpp
+@@ -73,7 +73,7 @@ void ExecWrapper::start(const BufferInfo& info, const QString& command)
+ if (!QFile::exists(fileName))
+ continue;
+ _process.setWorkingDirectory(scriptDir);
+- _process.start(_scriptName, params);
++ _process.start(fileName, params);
+ return;
+ }
+ emit error(tr("Could not find script \"%1\"").arg(_scriptName));
diff --git a/net-irc/quassel/quassel-0.14.0-r2.ebuild b/net-irc/quassel/quassel-0.14.0-r2.ebuild
index e0ce1c5cdfce..af4e2d872c26 100644
--- a/net-irc/quassel/quassel-0.14.0-r2.ebuild
+++ b/net-irc/quassel/quassel-0.14.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -105,6 +105,7 @@ DOCS=( AUTHORS ChangeLog README.md )
PATCHES=(
"${FILESDIR}/${P}-cxxflags.patch"
"${FILESDIR}/${P}-fix-desktop-application-name.patch"
+ "${FILESDIR}/${P}-fix-exec-script.patch"
)
src_configure() {