summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-03 04:00:51 +0100
committerSam James <sam@gentoo.org>2022-04-03 04:41:08 +0100
commit10f85b88567788188f22b3da118cbb38b4aa83f1 (patch)
tree525c876f8f553f3baa57f4c753b38f14b0278a9f /net-fs/libnfs
parentapp-admin/ansible: 5.5.0 bump (diff)
downloadgentoo-10f85b88567788188f22b3da118cbb38b4aa83f1.tar.gz
gentoo-10f85b88567788188f22b3da118cbb38b4aa83f1.tar.bz2
gentoo-10f85b88567788188f22b3da118cbb38b4aa83f1.zip
net-fs/libnfs: add 5.0.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs/libnfs')
-rw-r--r--net-fs/libnfs/Manifest1
-rw-r--r--net-fs/libnfs/files/libnfs-5.0.1-pthread-configure.patch34
-rw-r--r--net-fs/libnfs/libnfs-5.0.1.ebuild60
-rw-r--r--net-fs/libnfs/libnfs-9999.ebuild20
4 files changed, 107 insertions, 8 deletions
diff --git a/net-fs/libnfs/Manifest b/net-fs/libnfs/Manifest
index 9081fa425b0d..dfece8a6f904 100644
--- a/net-fs/libnfs/Manifest
+++ b/net-fs/libnfs/Manifest
@@ -1 +1,2 @@
DIST libnfs-4.0.0.tar.gz 251662 BLAKE2B b6c33c42eb1715b8a996a432b0cc28af1a98cca3389a779378df0931e4d37418937e3ea4938efb4d075b39aac33facca86df3a02bd62d2c7b262859e8d04ecc1 SHA512 3d93d83d1909f24de304c0d47fa6240da7ecf43ce2488a242a58ddabe51d774caf813f5a90ae720a8edd251a765b30e88c0e5b6a13ecb254dfecdc98e30737fa
+DIST libnfs-5.0.1.tar.gz 279550 BLAKE2B d27e97f3dce1385cabd8076b673d2bbfe339ff5a34295ca13bfea2f9c2048f4c6dd07a0b54b7cc7e44aecda58dd21520732dc6ee82260f0694a01fec59875a6a SHA512 71f2dcfa8945c1cb6402f5fca10b1f7a4720f7589807d6130eb55361f05ef4684f9cc9a177ece4e13d3847ac6606924115fac7b27749cecc2f5aca6fa9c63ebf
diff --git a/net-fs/libnfs/files/libnfs-5.0.1-pthread-configure.patch b/net-fs/libnfs/files/libnfs-5.0.1-pthread-configure.patch
new file mode 100644
index 000000000000..91c3781389b4
--- /dev/null
+++ b/net-fs/libnfs/files/libnfs-5.0.1-pthread-configure.patch
@@ -0,0 +1,34 @@
+https://github.com/sahlberg/libnfs/pull/380
+
+From af37ac6d766755185dc023b940cfe78a176170a0 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 3 Apr 2022 04:22:04 +0100
+Subject: [PATCH] autotools: fix syntax error in configure when pthreads
+ disabled
+
+Avoids this warning/syntax error in configure when pthreads aren't
+enabled (default):
+```
+checking for special C compiler options needed for large files... no
+checking for _FILE_OFFSET_BITS value needed for large files... no
+./configure: 14227: test: =: unexpected operator
+checking whether SO_BINDTODEVICE is available... yes
+checking whether getpwnam() is available... yes
+```
+
+The LHS of the test will be blank, so use an 'x' to give a dummy
+value, like we do elsewhere.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -88,7 +88,7 @@ if test x"$libnfs_cv_HAVE_PTHREAD" = x"yes"; then
+ AC_DEFINE(HAVE_MULTITHREADING,1,[Whether we have multithreading support])
+ fi
+ fi
+-AM_CONDITIONAL([HAVE_PTHREAD], [test $libnfs_cv_HAVE_PTHREAD = yes])
++AM_CONDITIONAL([HAVE_PTHREAD], [test x$libnfs_cv_HAVE_PTHREAD = xyes])
+
+ AC_MSG_CHECKING(whether SO_BINDTODEVICE is available)
+ AC_TRY_COMPILE([#include <net/if.h>], [
+
diff --git a/net-fs/libnfs/libnfs-5.0.1.ebuild b/net-fs/libnfs/libnfs-5.0.1.ebuild
new file mode 100644
index 000000000000..697b530e9448
--- /dev/null
+++ b/net-fs/libnfs/libnfs-5.0.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
+else
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86"
+ S="${WORKDIR}"/${PN}-${P}
+fi
+
+DESCRIPTION="Client library for accessing NFS shares over a network"
+HOMEPAGE="https://github.com/sahlberg/libnfs"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0/14" # sub-slot matches SONAME major
+IUSE="examples static-libs utils"
+
+# net-libs/rpcsvc-proto for rpcgen called in build system
+BDEPEND="net-libs/rpcsvc-proto
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/libnfs-5.0.1-pthread-configure.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable static-libs static)
+ $(use_enable utils)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ # --enable-examples configure switch just compiles them
+ # better install sources instead
+ exeinto /usr/share/doc/${PF}/examples/
+ for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
+ doexe examples/${program}.c
+ done
+ fi
+
+ find "${ED}" -name "*.la" -delete || die
+}
diff --git a/net-fs/libnfs/libnfs-9999.ebuild b/net-fs/libnfs/libnfs-9999.ebuild
index 2736936d4bfc..c586e1123012 100644
--- a/net-fs/libnfs/libnfs-9999.ebuild
+++ b/net-fs/libnfs/libnfs-9999.ebuild
@@ -1,31 +1,32 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
else
SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~x86"
- S="${WORKDIR}/${PN}-${P}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86"
+ S="${WORKDIR}"/${PN}-${P}
fi
DESCRIPTION="Client library for accessing NFS shares over a network"
HOMEPAGE="https://github.com/sahlberg/libnfs"
LICENSE="LGPL-2.1 GPL-3"
-SLOT="0/13" # sub-slot matches SONAME major
+SLOT="0/14" # sub-slot matches SONAME major
IUSE="examples static-libs utils"
-RDEPEND=""
-DEPEND="${RDEPEND}
+# net-libs/rpcsvc-proto for rpcgen called in build system
+BDEPEND="net-libs/rpcsvc-proto
virtual/pkgconfig"
src_prepare() {
default
+
eautoreconf
}
@@ -35,11 +36,13 @@ src_configure() {
$(use_enable static-libs static)
$(use_enable utils)
)
+
econf "${myeconfargs[@]}"
}
src_install() {
default
+
if use examples; then
# --enable-examples configure switch just compiles them
# better install sources instead
@@ -48,5 +51,6 @@ src_install() {
doexe examples/${program}.c
done
fi
+
find "${ED}" -name "*.la" -delete || die
}