summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-11 07:21:59 +0000
committerSam James <sam@gentoo.org>2024-11-11 07:21:59 +0000
commit9efaeddba63b1bd79743e77179f57b81ef4a2063 (patch)
treeed9b5c1b6a122a62b6a6a18a56bca73d282eeebc /net-dns
parentdev-libs/icu-le-hb: add 2.0.0 (diff)
downloadgentoo-9efaeddba63b1bd79743e77179f57b81ef4a2063.tar.gz
gentoo-9efaeddba63b1bd79743e77179f57b81ef4a2063.tar.bz2
gentoo-9efaeddba63b1bd79743e77179f57b81ef4a2063.zip
net-dns/c-ares: add 1.34.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/c-ares/Manifest2
-rw-r--r--net-dns/c-ares/c-ares-1.34.3.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/net-dns/c-ares/Manifest b/net-dns/c-ares/Manifest
index ba13462a82d2..7ad3a976b3b1 100644
--- a/net-dns/c-ares/Manifest
+++ b/net-dns/c-ares/Manifest
@@ -18,3 +18,5 @@ DIST c-ares-1.34.1.tar.gz 1008224 BLAKE2B 7094cf3a3fba4df6367d56c1d251d1f682b37b
DIST c-ares-1.34.1.tar.gz.asc 228 BLAKE2B 9d5dd6858e5686420c73ed269d6c5d3376f6fefe09122f993800c93682633995eb90e30a244e435f209a8014c32279949cfd044aa755852408ffa1b869431df8 SHA512 a198cae7cd010f31034835ae0b35d828aeccd443e56d3d04d18eb0fd2bcfa71847d3c3da66d8d15700400bd9576a2ee73aee08f3af2ee77f6d2219b2ff45e565
DIST c-ares-1.34.2.tar.gz 1008432 BLAKE2B 4879de256a35e33bbe37cfc3e7af14a6998821a36efbac6b26f265b6f8d782ee22016b92e9285efc745f6a667336c8c1c0b51b380fe9fbee295f73f62331e579 SHA512 ddcda2f4c82ece7d670d0beb11485253a0f0db1f01131164e7253a20405c081844d2c69e366300c76ca0419a025e0fed516ee54314443afc39d55ce292354ad9
DIST c-ares-1.34.2.tar.gz.asc 228 BLAKE2B 6338c1726907e893ae63927eb2ba31211f31857640d4c9659bc9b8ef84278bc873f0b744f1c449452bd6283ebd945eafc87135830f3b603363a63274c8e3f11c SHA512 f37cca24c2fcb3310ebfa4996a86a59a5b714005e42bb0019f590c70f60f0e0ececab0bbbb0826b5bed7423b8c18c23fa6efc16ab03420b154163917bf4e43c4
+DIST c-ares-1.34.3.tar.gz 997244 BLAKE2B fb66f4c8ae4c2e03e8f75ee72259dbe83d7bed5e72a7936f785121c3d02267375f67c734bae7213ec48bac9277d48e3bed4225fd03ba69dacd120b97dcc3e421 SHA512 f122d27cc76c20b41f9659b8bc662a8d82b857f8c066b1216b0349228d996224e42a7a0535bcdd6a3928b437c67d18726bfcb51c93f3a9801eebda6574e39c78
+DIST c-ares-1.34.3.tar.gz.asc 228 BLAKE2B 40e76fbc23a8aece1749a66499e469299e9df8174923ceeac788dd0ef0a8f029e79c550db1e8850e472b0d584215b52e3cedb5b7c4d3eb1daad8fc96864ad536 SHA512 f6ffcd6ef2571f51899f138d0f13003243e3031a2e4a1f96878c4fdd114c8682ee24c2826f9cfaa2022750058a2e11cb188972e9f369b87974b5abc351a5bc7b
diff --git a/net-dns/c-ares/c-ares-1.34.3.ebuild b/net-dns/c-ares/c-ares-1.34.3.ebuild
new file mode 100644
index 000000000000..6f65e746ad84
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.34.3.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Both Daniel and Brad are listed as possible signers on the homepage
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/bradhouse.asc
+inherit edo multilib-minimal verify-sig
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.org/"
+SRC_URI="
+ https://github.com/c-ares/c-ares/releases/download/v${PV}/${P}.tar.gz
+ verify-sig? ( https://github.com/c-ares/c-ares/releases/download/v${PV}/${P}.tar.gz.asc )
+"
+
+# ISC for lib/{bitncmp.c,inet_ntop.c,inet_net_pton.c} (bug #912405)
+LICENSE="MIT ISC"
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-cpp/gtest )
+ verify-sig? ( sec-keys/openpgp-keys-bradhouse )
+"
+
+DOCS=( AUTHORS README.md RELEASE-NOTES.md )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+A__QA_CONFIG_IMPL_DECL_SKIP=(
+ # Checking for obsolete headers
+ malloc
+ calloc
+ free
+
+ # Non-existent on Linux
+ closesocket
+ CloseSocket
+ ioctlsocket
+ bitncmp
+ ConvertInterfaceIndexToLuid
+ ConvertInterfaceLuidToNameA
+)
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # warnings are default, but enable -std=c90 which doesn't define
+ # 'bool' which is a type used/assumed in macOS system headers
+ sed -i -e 's/-std=c90/& -Dbool=int/' configure{.ac,} || die
+ # sysconfig integration requires deep framework compatibility
+ # and is not really desired in Prefix
+ sed -i -e 's/__APPLE__/__DISABLED__/' \
+ src/lib/ares_sysconfig_mac.c || die
+ sed -i -e '/elif defined(__APPLE__)/s/__APPLE__/__DISABLED__/' \
+ src/lib/ares_sysconfig.c || die
+ fi
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-symbol-hiding
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ )
+
+ # Needed for running unit tests only
+ # Violates sandbox and tests pass fine without
+ export ax_cv_uts_namespace=no
+ export ax_cv_user_namespace=no
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ cd "${BUILD_DIR}"/test || die
+
+ # We're skipping the "real" network tests with the filter
+ # see https://github.com/c-ares/c-ares/tree/main/test
+ local network_tests=(
+ # Most live tests have Live in the name
+ *Live*
+ # These don't but are still in ares-test-live.cc => live
+ *GetTCPSock*
+ *TimeoutValue*
+ *GetSock*
+ *GetSock_virtualized*
+ *VerifySocketFunctionCallback*
+ # Seems flaky, even run manually
+ # https://github.com/c-ares/c-ares/commit/9e542a8839f81c990bb0dff14beeaf9aa6bcc18d
+ *MockUDPMaxQueriesTest.GetHostByNameParallelLookups*
+ )
+
+ # The format for disabling test1, test2, and test3 looks like:
+ # -test1:test2:test3
+ edo ./arestest --gtest_filter=-$(echo $(IFS=:; echo "${network_tests[*]}"))
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}