summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/scmpc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/scmpc')
-rw-r--r--media-sound/scmpc/Manifest1
-rw-r--r--media-sound/scmpc/files/scmpc-2.init20
-rw-r--r--media-sound/scmpc/files/scmpc.init31
-rw-r--r--media-sound/scmpc/metadata.xml9
-rw-r--r--media-sound/scmpc/scmpc-0.4.1.ebuild32
5 files changed, 93 insertions, 0 deletions
diff --git a/media-sound/scmpc/Manifest b/media-sound/scmpc/Manifest
new file mode 100644
index 000000000000..cd84a571f004
--- /dev/null
+++ b/media-sound/scmpc/Manifest
@@ -0,0 +1 @@
+DIST scmpc-0.4.1.tar.bz2 88288 SHA256 f89958dc0449f1dfbcbe81b453986812196dc86200153ac700cf606297c3fde3 SHA512 7d9f8aad29d58f2227a6149a6b4c9bfc4d400946ac316cbb34482feffd71619c1f311cb1ce6f02c22912793e866661e4d976c8f4ee99ffd1e76be65c9a06d876 WHIRLPOOL 15036bae6c20670c5bc605f3c4b3a52a97f4527bdde6ac94788ec651c2f785bdc6c705644ae4937a7bf66a4ad498f858a14fbdbe4f821c007349e7026207fc62
diff --git a/media-sound/scmpc/files/scmpc-2.init b/media-sound/scmpc/files/scmpc-2.init
new file mode 100644
index 000000000000..e6165cc0e914
--- /dev/null
+++ b/media-sound/scmpc/files/scmpc-2.init
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net mpd
+}
+
+start() {
+ ebegin "Starting scmpc"
+ /usr/bin/scmpc -f /etc/scmpc.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping scmpc"
+ /usr/bin/scmpc -kf /etc/scmpc.conf
+ eend $?
+}
diff --git a/media-sound/scmpc/files/scmpc.init b/media-sound/scmpc/files/scmpc.init
new file mode 100644
index 000000000000..e9039da4a628
--- /dev/null
+++ b/media-sound/scmpc/files/scmpc.init
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+ use mpd
+}
+
+checkconfig() {
+ if ! [ -f /etc/scmpc.conf ]; then
+ eerror "Configuration file /etc/scmpc.conf does not exist."
+ return 1
+ fi
+
+ return 0
+}
+
+start () {
+ checkconfig || return 1
+
+ ebegin "Starting scmpc"
+ start-stop-daemon --start --exec /usr/bin/scmpc
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping scmpc"
+ start-stop-daemon --stop --exec /usr/bin/scmpc || eerror "scmpc is not running"
+ eend $?
+}
diff --git a/media-sound/scmpc/metadata.xml b/media-sound/scmpc/metadata.xml
new file mode 100644
index 000000000000..fb7ec4a9a25a
--- /dev/null
+++ b/media-sound/scmpc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/media-sound/scmpc/scmpc-0.4.1.ebuild b/media-sound/scmpc/scmpc-0.4.1.ebuild
new file mode 100644
index 000000000000..f51ad9644106
--- /dev/null
+++ b/media-sound/scmpc/scmpc-0.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="a client for MPD which submits your tracks to last.fm"
+HOMEPAGE="http://cmende.github.com/scmpc/"
+SRC_URI="http://dev.gentoo.org/~angelos/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/confuse
+ media-libs/libmpdclient
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md scmpc.conf.example )
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}-2.init ${PN}
+ insinto /etc
+ insopts -m600
+ newins scmpc.conf.example scmpc.conf
+}