summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-12-17 18:00:15 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-12-17 18:01:04 +0100
commit4044db3b1b9750f4386445662ae0dbd5609b6b07 (patch)
tree874aa9b5ac38d16da4683ab1401b81340a0010ce /media-sound/din/files
parentprofiles/package.mask: drop mask for dev-python/XenAPI (diff)
downloadgentoo-4044db3b1b9750f4386445662ae0dbd5609b6b07.tar.gz
gentoo-4044db3b1b9750f4386445662ae0dbd5609b6b07.tar.bz2
gentoo-4044db3b1b9750f4386445662ae0dbd5609b6b07.zip
media-sound/din: bump
1) eapi7 2) updated and organized deps 3) introduced alsa and jack use flags 4) updated relevant patches based on ebuild update by Samuel Bauer <samuel.bauer@yahoo.fr> Closes: https://bugs.gentoo.org/699358 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/din/files')
-rw-r--r--media-sound/din/files/din-43.0.1-fix-random-constants.patch15
-rw-r--r--media-sound/din/files/din-43.0.1-makefile.patch12
2 files changed, 27 insertions, 0 deletions
diff --git a/media-sound/din/files/din-43.0.1-fix-random-constants.patch b/media-sound/din/files/din-43.0.1-fix-random-constants.patch
new file mode 100644
index 000000000000..29f75d35f496
--- /dev/null
+++ b/media-sound/din/files/din-43.0.1-fix-random-constants.patch
@@ -0,0 +1,15 @@
+diff --git a/include/random.h b/include/random.h
+index 99d79fb..91ed250 100644
+--- a/include/random.h
++++ b/include/random.h
+@@ -16,8 +16,8 @@
+ const int N = 624;
+ const int M = 397;
+ const unsigned int MATRIX_A = 0x9908b0df; /* constant vector a */
+-const int UPPER_MASK = 0x80000000; /* most significant w-r bits */
+-const int LOWER_MASK = 0x7fffffff; /* least significant r bits */
++const unsigned int UPPER_MASK = 0x80000000; /* most significant w-r bits */
++const unsigned int LOWER_MASK = 0x7fffffff; /* least significant r bits */
+
+ static unsigned int mt[N]; /* the array for the state vector */
+ static int mti=N+1; /* mti==N+1 means mt[N] is not initialized */
diff --git a/media-sound/din/files/din-43.0.1-makefile.patch b/media-sound/din/files/din-43.0.1-makefile.patch
new file mode 100644
index 000000000000..f3a8116571cc
--- /dev/null
+++ b/media-sound/din/files/din-43.0.1-makefile.patch
@@ -0,0 +1,12 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index bcbd601..12ca52b 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,5 +1,5 @@
+-AM_CXXFLAGS = -I ../include -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -DPREFIX=\"@prefix@\"
+-LIBS += -ltcl8.6 -lSDL -lGL -lpthread -lasound
++AM_CXXFLAGS = -I ../include -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -DPREFIX=\"@prefix@\"
++LIBS += -ltcl -lSDL -lGL -lpthread -lasound
+
+ AM_CFLAGS = -I ../include
+ bin_PROGRAMS = din