summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2015-12-21 18:54:13 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2015-12-21 18:54:13 +0100
commitda0d78eb23ae9ae59725daf7dc5f1ddc0efbda02 (patch)
tree32463b1e6433cc1e46da6e9e0aeb8a10cfd9d4e1 /media-radio/unixcw
parentmedia-radio/unixcw: add SLOT deps for sys-libs/ncurses (diff)
downloadgentoo-da0d78eb23ae9ae59725daf7dc5f1ddc0efbda02.tar.gz
gentoo-da0d78eb23ae9ae59725daf7dc5f1ddc0efbda02.tar.bz2
gentoo-da0d78eb23ae9ae59725daf7dc5f1ddc0efbda02.zip
media-radio/unixcw: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-radio/unixcw')
-rw-r--r--media-radio/unixcw/Manifest1
-rw-r--r--media-radio/unixcw/unixcw-3.5.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-radio/unixcw/Manifest b/media-radio/unixcw/Manifest
index 1268caaadbbf..b614d7b7e5b0 100644
--- a/media-radio/unixcw/Manifest
+++ b/media-radio/unixcw/Manifest
@@ -1 +1,2 @@
DIST unixcw-3.4.2.tar.gz 730461 SHA256 ace7d16cfc8f84ffe041de6774baa0727ed0230657cf8a93cb4addf1cb4e8b2a SHA512 118e4f7fcca78713e5be5aa2faccec4e26979e95dcc300bf259534bb417eee7b21591ecb778467591b1a3b61c9ede18f229f88cd1bba2d6bc54f4d410096e0c9 WHIRLPOOL e8959ccb6eca32f4d468dbdb1add61dad6be30b453369385a1c857309ea89d052e4ef5577c4e17f101a79ee762f10ead3ec1fae72a394455ac473c4758fe0e3c
+DIST unixcw-3.5.0.tar.gz 739258 SHA256 82c455b67c6444165ec59f75bc29ad0665b79d70489bd09e3166fd1ccde718e6 SHA512 82128656dce56558f4a41be394afd1579f9de43f170c695e09e25e231b8416993b1cb94215325b39645391b2a43ede8119291efad284fecc35eb8a753669e8ec WHIRLPOOL 3c6dd3bcfa4d43f114938a1048e04f21a63199bb7c291e415e5b035dfe6c59031c60760ad65721cea84ee942ef6263f1938fa9093e6ab6c620875433b415c878
diff --git a/media-radio/unixcw/unixcw-3.5.0.ebuild b/media-radio/unixcw/unixcw-3.5.0.ebuild
new file mode 100644
index 000000000000..8f624adceba2
--- /dev/null
+++ b/media-radio/unixcw/unixcw-3.5.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="A package of programs that fit together to form a morse code tutor program"
+HOMEPAGE="http://unixcw.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="alsa ncurses pulseaudio suid qt5"
+
+RDEPEND="ncurses? ( sys-libs/ncurses:= )
+ qt5? ( dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5 )
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool
+ !<=app-misc/cw-1.0.16-r1"
+
+src_prepare() {
+ append-cflags -std=gnu99
+}
+
+src_configure() {
+ econf --libdir=/usr/$(get_libdir) \
+ $(use_enable pulseaudio ) \
+ $(use_enable alsa ) \
+ $(use_enable ncurses cwcp ) \
+ $(use_enable qt5 xcwcp )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+ dodoc ChangeLog NEWS README
+ if ! use suid ; then
+ fperms 711 /usr/bin/cw
+ if use ncurses ; then
+ fperms 711 /usr/bin/cwcp
+ fi
+ if use qt5 ; then
+ fperms 711 /usr/bin/xcwcp
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use suid ; then
+ ewarn "You have choosen to install 'cw', 'cwcp' and 'xcwcp' setuid"
+ ewarn "by setting USE=suid."
+ ewarn "Be aware that this is a security risk and not recommended."
+ ewarn ""
+ ewarn "These files do only need root access if you want to use the"
+ ewarn "PC speaker for morse sidetone output. You can alternativly"
+ ewarn "drop USE=suid and use sudo."
+ else
+ elog "Be aware that 'cw', 'cwcp' and 'xcwcp' needs root access if"
+ elog "you want to use the PC speaker for morse sidetone output."
+ elog "You can call the programs via sudo for that (see 'man sudo')."
+ fi
+}