summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-06 08:46:11 +0000
committerSam James <sam@gentoo.org>2023-04-12 08:35:06 +0100
commit161057ae8ccd0aaa0ed11c772dd61efe00dfa933 (patch)
tree86fa6a81b4aea7960bfae85afb7bcc6074c1ccba /media-libs
parentmedia-libs/exiftool: Add 12.59 (diff)
downloadgentoo-161057ae8ccd0aaa0ed11c772dd61efe00dfa933.tar.gz
gentoo-161057ae8ccd0aaa0ed11c772dd61efe00dfa933.tar.bz2
gentoo-161057ae8ccd0aaa0ed11c772dd61efe00dfa933.zip
media-libs/exiftool: add 12.60
latest stable production release. Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/30396 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/exiftool/Manifest1
-rw-r--r--media-libs/exiftool/exiftool-12.60.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/exiftool/Manifest b/media-libs/exiftool/Manifest
index ea71c4d80b92..263e6fad3c18 100644
--- a/media-libs/exiftool/Manifest
+++ b/media-libs/exiftool/Manifest
@@ -1,3 +1,4 @@
DIST Image-ExifTool-12.42.tar.gz 5042086 BLAKE2B c518906dfc6c354a6bf834044322727ff0c6787f74c387fb24b2320072bb525fd8b0b55d74cc324ac6e2ad6e75de0f3c552db2f6a1e665ab4b1bed9117916c2b SHA512 f7d3dd98623f44473f67ccf740370fd7704b60274efe1272b5219599dba9fe312afe4107937c6d64c5ee11380914b6e97a5248a2abcf88820822f9947cae0f8f
DIST Image-ExifTool-12.50.tar.gz 5088286 BLAKE2B bfc0eae786e1443df5f741f5deed339b76b3041ab939c45303775df9ad22d989bbd68b77c9b8f2259c493dd81828b31223e604ef8bb4867c952cfb892a38a9d5 SHA512 d95be3636ed139a41a14183fc31fa2ecb5ea71b570ccdd282b9f0bba84a264b2edff2c42b34ee1114a14b106383d5ab3b67b8e73642e534f4df3fa54082dba85
DIST Image-ExifTool-12.59.tar.gz 5202827 BLAKE2B 00a88c3c7239dbcb086469ea5929005ba5bee3230f043bf516fdac92f758ea36fab99f5667a25a7216b35f409d62db3d9cf27b075c0d8ef680e1fbb2b921a3eb SHA512 e17fc293b71a00ae083017f01c50f346cad06f095b7ba279033097285e9f0cdbb917e7b09f1cac6515113e096ca34dafe8eb48fbaa617e62a5fd3dffff505356
+DIST Image-ExifTool-12.60.tar.gz 5204922 BLAKE2B 6b4012d722153756a1bb289422d5546395d0be185fcbdc9b954aa3a4d6814ca36fbfc19053889ec864bebe229b4857dc0f9b00b551d1d369de3b97facb7e6117 SHA512 3a581bfd5a75b48b13063f4d169cc167fd027c029bf5d05111d51e789ce9344dcec40b3b7e4f6a9e10ce5599ece514bc0689e93b3aef6bd7db1498537d10899f
diff --git a/media-libs/exiftool/exiftool-12.60.ebuild b/media-libs/exiftool/exiftool-12.60.ebuild
new file mode 100644
index 000000000000..4602af41803e
--- /dev/null
+++ b/media-libs/exiftool/exiftool-12.60.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check https://exiftool.org/history.html for whether a release is 'production'
+# Ideally don't bump to non-production at all, but certainly don't stable.
+
+DIST_NAME=Image-ExifTool
+inherit perl-module
+
+DESCRIPTION="Read and write meta information in image, audio and video files"
+HOMEPAGE="https://exiftool.org/ http://exiftool.sourceforge.net"
+SRC_URI="https://exiftool.org/${DIST_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="doc"
+
+src_install() {
+ perl-module_src_install
+ use doc && dodoc -r html/
+
+ insinto /usr/share/${PN}
+ doins -r fmt_files config_files arg_files
+}