summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/sdl-terminal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/sdl-terminal')
-rw-r--r--media-libs/sdl-terminal/Manifest1
-rw-r--r--media-libs/sdl-terminal/files/sdl-terminal-1.1.3-nopython.patch24
-rw-r--r--media-libs/sdl-terminal/metadata.xml5
-rw-r--r--media-libs/sdl-terminal/sdl-terminal-1.1.3-r1.ebuild39
4 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/sdl-terminal/Manifest b/media-libs/sdl-terminal/Manifest
new file mode 100644
index 000000000000..f85e455ae0ef
--- /dev/null
+++ b/media-libs/sdl-terminal/Manifest
@@ -0,0 +1 @@
+DIST SDL_terminal-1.1.3.tar.gz 466321 SHA256 6fcfa44cb96da3be15fd7565eade018e9ac1d649a41c05e9b819f8714537e864 SHA512 be6e74430ac9467e58fde6048b042db319940e564061b6e537f45dcbd54148f5df593dd0b8a28d866ae298d0f1c8f3a113bf23640c25213c6784ede5233882ef WHIRLPOOL 279d89b43fba9c4d30fc820bdf0948d93b89ba55acaadc4f25a715454d14c135fa4be15872d35029209ef0d8a5fadc9ba54af9614f9fa2310fd05f0c201c7741
diff --git a/media-libs/sdl-terminal/files/sdl-terminal-1.1.3-nopython.patch b/media-libs/sdl-terminal/files/sdl-terminal-1.1.3-nopython.patch
new file mode 100644
index 000000000000..c9d3214dd091
--- /dev/null
+++ b/media-libs/sdl-terminal/files/sdl-terminal-1.1.3-nopython.patch
@@ -0,0 +1,24 @@
+--- configure.ac.old 2014-07-22 14:19:33.797413503 +0200
++++ configure.ac 2014-07-22 14:19:55.293201011 +0200
+@@ -108,7 +108,6 @@
+ fi
+ AC_SUBST(GL_LIBS)
+
+-AC_PYTHON_DEVEL
+
+ # Finally create all the generated files
+ # The configure script takes "file.in" and substitutes variables to produce
+@@ -118,5 +117,4 @@
+ Makefile
+ src/Makefile
+ include/Makefile
+-examples/Makefile
+ ])
+--- Makefile.am.old 2014-07-22 14:19:40.729344917 +0200
++++ Makefile.am 2014-07-22 14:20:06.353091713 +0200
+@@ -1,4 +1,4 @@
+ ## Process this file with automake to produce Makefile.in
+
+-SUBDIRS = src include examples
++SUBDIRS = src include
+
diff --git a/media-libs/sdl-terminal/metadata.xml b/media-libs/sdl-terminal/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/media-libs/sdl-terminal/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/media-libs/sdl-terminal/sdl-terminal-1.1.3-r1.ebuild b/media-libs/sdl-terminal/sdl-terminal-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..e78133814abf
--- /dev/null
+++ b/media-libs/sdl-terminal/sdl-terminal-1.1.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit base libtool autotools
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="library that provides a pseudo-ansi color terminal that can be used with any SDL application"
+HOMEPAGE="http://sourceforge.net/projects/sdl-terminal/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+DEPEND="virtual/opengl
+ virtual/glu
+ >=media-libs/libsdl-1.2.4
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nopython.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}