summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-08-26 13:53:46 +0100
committerSam James <sam@gentoo.org>2022-08-26 14:08:02 +0100
commit36d23e2261ec68bc8d624a8cdebeb8c06c1aad66 (patch)
tree67ca8353d67df883700c1fb810becd636dcc4da3 /media-libs/gst-plugins-good
parentmedia-libs/gst-plugins-base: add 1.20.3 (diff)
downloadgentoo-36d23e2261ec68bc8d624a8cdebeb8c06c1aad66.tar.gz
gentoo-36d23e2261ec68bc8d624a8cdebeb8c06c1aad66.tar.bz2
gentoo-36d23e2261ec68bc8d624a8cdebeb8c06c1aad66.zip
media-libs/gst-plugins-good: add 1.20.3
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/Manifest1
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.20.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
index 0d98242fa2b2..8035d1759b43 100644
--- a/media-libs/gst-plugins-good/Manifest
+++ b/media-libs/gst-plugins-good/Manifest
@@ -1 +1,2 @@
DIST gst-plugins-good-1.20.2.tar.xz 3411008 BLAKE2B 45eb497d240bf9b05cfbf85babe5ef85fb8a7f25f1b470f131f319064e1dc04f334d4b7dede4f0aedd73dca01605b7e00e2ddc587bcf9ccce6989a9e99776cb1 SHA512 a10ea48fdfbe741e9bc63036b011748558f89968aaa525380ac99884c27463d190c0b49e2d98b4f554eee6ead8a5c5da3ba62e5b0b1fe54877598beccc68a933
+DIST gst-plugins-good-1.20.3.tar.xz 3417252 BLAKE2B 5f288541598d2c308fbb1d5e36e54e8dd4c6e9d7dd71f41b778fbdfe883ed48e8d13fa53d05518cc671de029d804f7dc1d93396de9d199d45ec131230926d33c SHA512 98bb2dd428edaa1a5846fb47b1f42a1e99541faf05cdb0fb632d4a1a1e4fb2c1f9d1229bf0aa2ddcbce139533e9fd51f8f9a1175cd8a8729c5179750ca84afa1
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.20.3.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.20.3.ebuild
new file mode 100644
index 000000000000..350fe1793a50
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.20.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit gstreamer-meson
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+orc"
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+# Fixes backported to 1.20.1, to be removed in 1.20.2+
+PATCHES=(
+)
+
+multilib_src_configure() {
+ GST_PLUGINS_NOAUTO="bz2"
+
+ local emesonargs=(
+ -Dbz2=enabled
+
+ # gst-plugins-ximagesrc
+ -Dximagesrc=disabled
+ -Dximagesrc-xshm=disabled
+ -Dximagesrc-xfixes=disabled
+ -Dximagesrc-xdamage=disabled
+
+ # gst-plugins-v4l2
+ -Dv4l2=disabled
+ )
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}