summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-09 11:11:06 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-09 11:41:40 -0800
commitf8117eed50ebcac3d4149b9a522969a3ba74e151 (patch)
treec995031eace416975bba94c807d89b4e4c90c55c /gnome-extra
parentgnome-extra/evolution-data-server: Version bump to 3.42.3 (diff)
downloadgentoo-f8117eed50ebcac3d4149b9a522969a3ba74e151.tar.gz
gentoo-f8117eed50ebcac3d4149b9a522969a3ba74e151.tar.bz2
gentoo-f8117eed50ebcac3d4149b9a522969a3ba74e151.zip
gnome-extra/evolution-ews: Version bump to 3.42.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.42.3.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index cbeda195b218..19344ac29416 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -2,3 +2,4 @@ DIST evolution-ews-3.40.3.tar.xz 673800 BLAKE2B 4d8cbce33552a40551db08f25bb784ec
DIST evolution-ews-3.40.4.tar.xz 673888 BLAKE2B 532b708795db3ffdff69b44d31c49ff9c4800b527b09d4440b383a16f6ad283cea5ebdfae5cf104e08d8f2166d7269d6810d4ae6ead2c55af7f77633292d7376 SHA512 7f89e8cebf5931bd7d2f636b1780d914f069fb62ac4e14ad0ab2c9759e4553bc5d58a53b65a635c7b5be298fc017f375f9ca4d1c96002804093b9f47107455f2
DIST evolution-ews-3.42.0.tar.xz 682796 BLAKE2B 6b9fe9d2cae4be586d0cc96188a9e4b10c2fdc3ba0044b19daac70039019f2422416899a7c020c633d473372d424c826aa3a78b5d4b6f0d091364d9db6786ce2 SHA512 62e912827a31b6cf23b572206f27981b255d27cccd252209b1927eb99e39ad6a9a3db7e0c410664c81ff6dfa2156cf0853ea211de3e8fdb4c26db22b19f9ddd9
DIST evolution-ews-3.42.1.tar.xz 685356 BLAKE2B b3be78f64fbac8fac5fca284850e214304a1b8fdad7354a7ce5134fa12514d36425bf8b841c1a21c58df5604f94a86650325efc052bd5f826105a7d5d001deaf SHA512 42dd9a935d6bd59ccd54340b92fcbaf31c262234563928792116edc31bdf5b078caa8fba0d54084ce168f243652a890e02d3789d44512bcfc808083515bd5e32
+DIST evolution-ews-3.42.3.tar.xz 685692 BLAKE2B 6e9a06c78d54f119e0d942dc830d118fc7a0b19c16fa3729491b695ac01c582b1124d895d3f56ccadf72fca5716491f29a6ca6ac216fea2ea2cd1a26bdd3f5ed SHA512 e740796e4c4afc8946592195d21aac2171724cad6069001c7d2af36f1deb8d25f89ce825898faa9e042fb6e32571f7556579bf984da0573118739e314fb7bff9
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.42.3.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.42.3.ebuild
new file mode 100644
index 000000000000..e3822dd52ce6
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.42.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.62:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/uhttpmock )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}