summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-01 04:58:38 +0000
committerSam James <sam@gentoo.org>2024-03-01 07:54:38 +0000
commit9e6ea59788793f9fb4a0e7781b1737c93c76123c (patch)
tree6a92e0d4a4899e1e721fceebbecc30653943660f /games-strategy/warzone2100
parentgames-strategy/warzone2100: drop 4.3.5, 4.4.0-r1 (diff)
downloadgentoo-9e6ea59788793f9fb4a0e7781b1737c93c76123c.tar.gz
gentoo-9e6ea59788793f9fb4a0e7781b1737c93c76123c.tar.bz2
gentoo-9e6ea59788793f9fb4a0e7781b1737c93c76123c.zip
games-strategy/warzone2100: filter LTO (ODR violations)
There's a lot of bundled code in warzone, but the issue here is the standard Bison yy_* remapping ODR thing. Closes: https://bugs.gentoo.org/859268 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy/warzone2100')
-rw-r--r--games-strategy/warzone2100/warzone2100-4.4.2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/games-strategy/warzone2100/warzone2100-4.4.2.ebuild b/games-strategy/warzone2100/warzone2100-4.4.2.ebuild
index 42252a5e12cf..d3acd7fee1f3 100644
--- a/games-strategy/warzone2100/warzone2100-4.4.2.ebuild
+++ b/games-strategy/warzone2100/warzone2100-4.4.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PLOCALES="af_ZA bg_BG ca_ES cs da de el en_GB eo es et_EE fa_IR fi fr fy ga he_IL hr hu id_ID id it ko la lt nb nl pl pt_BR pt ro ru sk sl tr tt_RU uk_UA zh_CN zh_TW"
-inherit cmake plocale xdg
+inherit cmake flag-o-matic plocale xdg
MY_PV=$(ver_cut 1-2)
VIDEOS_PV=2.2
@@ -87,6 +87,9 @@ src_prepare() {
}
src_configure() {
+ # ODR violations (bison, yy_*, bug #859268)
+ filter-lto
+
# TODO: unbundle dev-cpp/nlohmann_json
# TODO: unbundle dev-libs/libfmt
# TODO: unbundle SQLiteCpp