summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-08 06:45:12 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-08 07:57:49 -0500
commit178b678803ca6a2b6bfd33033de41866142997cb (patch)
treeddd99de734f780bc571c881537a72a65c47a5375 /games-emulation/mgba/mgba-9999.ebuild
parentgames-emulation/mgba: drop 0.10.2-r0 (diff)
downloadgentoo-178b678803ca6a2b6bfd33033de41866142997cb.tar.gz
gentoo-178b678803ca6a2b6bfd33033de41866142997cb.tar.bz2
gentoo-178b678803ca6a2b6bfd33033de41866142997cb.zip
games-emulation/mgba: do preinst shader merge workaround in live
See ebuild comment. Users that have been using 9999 may need to manually delete these directories to get shaders to be merged (this is otherwise in preparation for the 0.11.0 release). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/mgba/mgba-9999.ebuild')
-rw-r--r--games-emulation/mgba/mgba-9999.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/games-emulation/mgba/mgba-9999.ebuild b/games-emulation/mgba/mgba-9999.ebuild
index 91e0309f70ac..d4ce0e18832b 100644
--- a/games-emulation/mgba/mgba-9999.ebuild
+++ b/games-emulation/mgba/mgba-9999.ebuild
@@ -117,3 +117,12 @@ src_install() {
rm -r "${ED}"/usr/share/doc/${PF}/{LICENSE,licenses} || die
}
+
+pkg_preinst() {
+ # hack: .shader/ were directories in <0.11 and are now single (zip) files
+ # named the same, that leads to portage mis-merging and leaving an empty
+ # directory behind rather than the new file
+ if use gui && has_version '<games-emulation/mgba-0.11[gui]'; then
+ rm -rf -- "${EROOT}"/usr/share/mgba/shaders/*.shader/ || die
+ fi
+}