summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-17 13:17:36 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-17 15:55:24 -0400
commit3323784cbb44cb2df81c86345e90d77a6d816c59 (patch)
treebbbc88eb1704487ca48d045b2cbbe15a7111f52f /games-board
parentdev-util/d-spy: Version bump to 1.6.0 (diff)
downloadgentoo-3323784cbb44cb2df81c86345e90d77a6d816c59.tar.gz
gentoo-3323784cbb44cb2df81c86345e90d77a6d816c59.tar.bz2
gentoo-3323784cbb44cb2df81c86345e90d77a6d816c59.zip
games-board/gnome-chess: Version bump to 43.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30184 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnome-chess/Manifest1
-rw-r--r--games-board/gnome-chess/gnome-chess-43.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index 37ee0feadae1..d4f4253422cb 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1 +1,2 @@
DIST gnome-chess-43.1.tar.xz 743100 BLAKE2B b2fb2594cab3d0fa82d682db931911c71df9f4fca0707c39a15c5f5caa397a34e6a132e09950fb41ece01873a87d60e91df1e5397830cfa700427e3b119c95cc SHA512 d42fb3f960030813d2551c2f0dac46068f30992934e9f8779a097a1ca43a7711b64c0f499eff3ecd698325f5e2458f03c0a9b6cd4c333ad4ca9dba83faa833c5
+DIST gnome-chess-43.2.tar.xz 743344 BLAKE2B 755d70ef964f6337acf852edc6fdbe69fbf3b566dfc36fa697d4c4ecdeeae5df5d1979e54e3304e89963fab01655979a55ac4f827bb1f1b506ab3cea8d147117 SHA512 e10439dd39e61436e3174e1d599d30d06955e65b696b9c37a0e9a8f1a41d19f71f33cca83ec9cc8fe2d8b516c2ec113f22bf3ddd1f1f465286cbe5bde8bcc0a2
diff --git a/games-board/gnome-chess/gnome-chess-43.2.ebuild b/games-board/gnome-chess/gnome-chess-43.2.ebuild
new file mode 100644
index 000000000000..ffb3da44acf5
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-43.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess https://gitlab.gnome.org/GNOME/gnome-chess"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ gui-libs/gtk:4
+ >=gui-libs/libadwaita-1.0.0:1
+ >=gnome-base/librsvg-2.46.0:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg:2[vala]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-util/itstool
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To be able to play against a computer you will need
+to install a chess engine package, for example games-board/gnuchess"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}