summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/qgo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/qgo')
-rw-r--r--games-board/qgo/Manifest1
-rw-r--r--games-board/qgo/files/qgo-1.5.4_p20100322-buffer.patch11
-rw-r--r--games-board/qgo/files/qgo-1.5.4_p20100322-gcc45.patch77
-rw-r--r--games-board/qgo/files/qgo-1.5.4_p20100322-qt47.patch74
-rw-r--r--games-board/qgo/metadata.xml5
-rw-r--r--games-board/qgo/qgo-1.5.4_p20100322.ebuild53
6 files changed, 221 insertions, 0 deletions
diff --git a/games-board/qgo/Manifest b/games-board/qgo/Manifest
new file mode 100644
index 000000000000..43bab980b005
--- /dev/null
+++ b/games-board/qgo/Manifest
@@ -0,0 +1 @@
+DIST qgo-1.5.4_p20100322.tar.bz2 2486631 SHA256 08848ef8fc05b0f32ec730f0ac0e7123224e8b69f251ef9aeb711c9a2fceefa9 SHA512 bdb6e5147cc0847ca0cf776ecce5a00af9ebc7bb06d148b79bf073d15fdcfe494a2d71d3fd1c2aa29ea70735fb3208b9b9be42adcb84c894c9d419c12d60f2a6 WHIRLPOOL 9b3320c97eef5bf4e75b3d21fcade76e16d37d6061280de56ceba43bf9e3d4b81a4124288bbe86dbe568a09c7f3ac3533df5ac836477e5adfb9f9941622dcc8c
diff --git a/games-board/qgo/files/qgo-1.5.4_p20100322-buffer.patch b/games-board/qgo/files/qgo-1.5.4_p20100322-buffer.patch
new file mode 100644
index 000000000000..cb0f0156dd3b
--- /dev/null
+++ b/games-board/qgo/files/qgo-1.5.4_p20100322-buffer.patch
@@ -0,0 +1,11 @@
+--- src/network/tygemconnection.cpp.orig 2014-10-29 23:49:21.436929924 -0400
++++ src/network/tygemconnection.cpp 2014-10-29 23:50:43.481183852 -0400
+@@ -4768,7 +4768,7 @@
+ unsigned int i;
+
+ QString encoded_name;
+- name[15] = 0x00;
++ name[14] = 0x00;
+ int records = (msg[0] << 8) + msg[1];
+ if((records * 16) + 4 != (int)size)
+ {
diff --git a/games-board/qgo/files/qgo-1.5.4_p20100322-gcc45.patch b/games-board/qgo/files/qgo-1.5.4_p20100322-gcc45.patch
new file mode 100644
index 000000000000..53c8509bc255
--- /dev/null
+++ b/games-board/qgo/files/qgo-1.5.4_p20100322-gcc45.patch
@@ -0,0 +1,77 @@
+--- src/board/board.cpp.old 2010-06-01 08:20:32.000000000 +0200
++++ src/board/board.cpp 2010-06-01 08:20:54.000000000 +0200
+@@ -347,7 +347,7 @@
+ }
+
+ //redraws the image on a brush to set the background
+- canvas->setBackgroundBrush ( QBrush::QBrush(image));
++ canvas->setBackgroundBrush ( QBrush(image));
+
+ }
+
+--- src/board/clockdisplay.cpp.old 2010-06-01 08:31:10.000000000 +0200
++++ src/board/clockdisplay.cpp 2010-06-01 08:31:38.000000000 +0200
+@@ -274,13 +274,13 @@
+
+ if(b_time > 3600 || w_time > 3600)
+ {
+- bt = QTime::QTime(0,0).addSecs(abs(b_time)).toString("h:mm:ss") ;
+- wt = QTime::QTime(0,0).addSecs(abs(w_time)).toString("h:mm:ss") ;
++ bt = QTime(0,0).addSecs(abs(b_time)).toString("h:mm:ss") ;
++ wt = QTime(0,0).addSecs(abs(w_time)).toString("h:mm:ss") ;
+ }
+ else
+ {
+- bt = QTime::QTime(0,0).addSecs(abs(b_time)).toString("m:ss") ;
+- wt = QTime::QTime(0,0).addSecs(abs(w_time)).toString("m:ss") ;
++ bt = QTime(0,0).addSecs(abs(b_time)).toString("m:ss") ;
++ wt = QTime(0,0).addSecs(abs(w_time)).toString("m:ss") ;
+ }
+
+ switch(timeSystem)
+--- src/gtp/qgtp.cpp.old 2010-06-01 08:34:09.000000000 +0200
++++ src/gtp/qgtp.cpp 2010-06-01 08:34:28.000000000 +0200
+@@ -341,7 +341,7 @@
+ _cpt++;
+
+ qDebug("flush -> %s",s);
+- uint i= programProcess->write(QByteArray::QByteArray(s));
++ uint i= programProcess->write(QByteArray(s));
+
+ // int j= programProcess->waitForBytesWritten ( 100 );
+
+--- src/board/imagehandler.cpp.old 2010-06-01 08:34:55.000000000 +0200
++++ src/board/imagehandler.cpp 2010-06-01 08:35:17.000000000 +0200
+@@ -93,8 +93,8 @@
+ {
+ altGhostPixmaps = new QList<QPixmap>();//::QList();
+
+- QPixmap alt1 = QPixmap::QPixmap(":/new/prefix1/ressources/pics/alt_ghost_black.png");
+- QPixmap alt2 = QPixmap:: QPixmap(":/new/prefix1/ressources/pics/alt_ghost_white.png");
++ QPixmap alt1 = QPixmap(":/new/prefix1/ressources/pics/alt_ghost_black.png");
++ QPixmap alt2 = QPixmap(":/new/prefix1/ressources/pics/alt_ghost_white.png");
+
+ if (alt1.isNull() || alt2.isNull())
+ qFatal("Could not load alt_ghost pixmaps.");
+--- src/board/mark.cpp.old 2010-06-01 08:36:39.000000000 +0200
++++ src/board/mark.cpp 2010-06-01 08:36:51.000000000 +0200
+@@ -109,7 +109,7 @@
+ setPen(QPen(col, 2));
+ // else
+
+- pa = QPolygon::QPolygon(3);
++ pa = QPolygon(3);
+
+ // setPen(QPen(col, 1));
+ setSize(s, s);
+--- src/network/gamedialog.cpp.old 2010-06-01 08:45:26.000000000 +0200
++++ src/network/gamedialog.cpp 2010-06-01 08:45:40.000000000 +0200
+@@ -1123,7 +1123,7 @@
+ * probably FIXME, I just wonder why its like that in the first place */
+
+ QPalette p(QApplication::palette());
+- p.setColor( QPalette::Base , QColor::QColor("cyan"));
++ p.setColor( QPalette::Base , QColor("cyan"));
+
+ qDebug("GameDialog::recvRequest");
+ /* If there's no existing request, then nothing should have changed
diff --git a/games-board/qgo/files/qgo-1.5.4_p20100322-qt47.patch b/games-board/qgo/files/qgo-1.5.4_p20100322-qt47.patch
new file mode 100644
index 000000000000..bf8bfee3cce2
--- /dev/null
+++ b/games-board/qgo/files/qgo-1.5.4_p20100322-qt47.patch
@@ -0,0 +1,74 @@
+--- src/network/playergamelistings.h.old 2010-11-08 13:49:25.000000000 +0100
++++ src/network/playergamelistings.h 2010-11-08 13:52:24.000000000 +0100
+@@ -66,21 +66,21 @@
+ bool hidden;
+ PlayerListing() : id(0),
+ online(0),
+- name(0),
+- notnickname(0),
+- info(0),
+- idletime(0),
++ name(QString::null),
++ notnickname(QString::null),
++ info(QString::null),
++ idletime(QString::null),
+ seconds_idle(0),
+- rank(0),
++ rank(QString::null),
+ rank_score(0),
+- country(0),
++ country(QString::null),
+ wins(0),
+ losses(0),
+ rated_games(0),
+ observing(0),
+ playing(0),
+- extInfo(0),
+- email_address(0),
++ extInfo(QString::null),
++ email_address(QString::null),
+ nmatch(0),
+ nmatch_handicapMin(0),
+ specialbyte(0),
+@@ -189,7 +189,7 @@
+ _white_rank_score(0),
+ _black_rank_score(0),
+ observers(0),
+- result(0),
++ result(QString::null),
+ flags(IN_PROGRESS),
+ rated(0),
+ owner_id(0),
+--- src/board/board.h.old 2010-11-08 13:57:26.000000000 +0100
++++ src/board/board.h 2010-11-08 13:58:17.000000000 +0100
+@@ -50,7 +50,7 @@
+
+ void removeGhosts();
+ void setVarGhost(StoneColor c, int x, int y);
+- void setMark(int x, int y, MarkType t, bool update=true, QString txt=0, bool overlay=true);
++ void setMark(int x, int y, MarkType t, bool update=true, QString txt=QString::null, bool overlay=true);
+ Mark* hasMark(int x, int y);
+ void removeMark(int x, int y, bool update = false);
+ void removeDeadMarks();
+--- src/board/boardwindow.h.old 2010-11-08 14:21:19.000000000 +0100
++++ src/board/boardwindow.h 2010-11-08 14:21:39.000000000 +0100
+@@ -45,7 +45,7 @@
+ ~BoardWindow();
+
+ void init();
+- bool loadSGF(const QString fileName, const QString SGFLoaded=0);
++ bool loadSGF(const QString fileName, const QString SGFLoaded=QString::null);
+ bool doSave(QString fileName, bool force);
+ QString getCandidateFileName();
+
+--- src/sgf/sgfparser.h.old 2010-11-08 14:29:05.000000000 +0100
++++ src/sgf/sgfparser.h 2010-11-08 14:29:27.000000000 +0100
+@@ -51,7 +51,7 @@
+ */
+ protected:
+ int minPos(int n1, int n2, int n3);
+- bool corruptSgf(int where=0, QString reason=NULL);
++ bool corruptSgf(int where=0, QString reason=QString::null);
+
+ bool parseProperty(const QString &toParse, const QString &prop, QString &result);
+
diff --git a/games-board/qgo/metadata.xml b/games-board/qgo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/qgo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-board/qgo/qgo-1.5.4_p20100322.ebuild b/games-board/qgo/qgo-1.5.4_p20100322.ebuild
new file mode 100644
index 000000000000..b01bff68b3f0
--- /dev/null
+++ b/games-board/qgo/qgo-1.5.4_p20100322.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils qt4-r2 games
+
+DESCRIPTION="An ancient boardgame, very common in Japan, China and Korea"
+HOMEPAGE="http://qgo.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/alsa-lib
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qttest:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "/QGO_INSTALL_PATH/s:/usr/share:${GAMES_DATADIR}:" \
+ -e "/QGO_INSTALL_BIN_PATH/s:/usr/bin:${GAMES_BINDIR}:" \
+ -e 's:$(QTDIR)/bin/lrelease:lrelease:' \
+ src/src.pro || die
+
+ sed -i \
+ -e "/TRANSLATIONS_PATH_PREFIX/s:/usr/share:${GAMES_DATADIR}:" \
+ src/defines.h || die
+
+ epatch \
+ "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-qt47.patch \
+ "${FILESDIR}"/${P}-buffer.patch
+}
+
+src_configure() {
+ eqmake4 qgo2.pro
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ dodoc AUTHORS
+
+ insinto "${GAMES_DATADIR}"/qgo/languages
+ doins src/translations/*.qm
+
+ prepgamesdirs
+}