summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-28 12:11:06 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-28 12:42:39 -0400
commit59d9c1824d3b9a3200d298db15bd82ddb1c42987 (patch)
treee77d13d508753cbfff90f17d916cca112eaf7abd /games-arcade/xscavenger/xscavenger-1.4.5.ebuild
parentgames-arcade/vor: drop 0.5.7-r1 (diff)
downloadgentoo-59d9c1824d3b9a3200d298db15bd82ddb1c42987.tar.gz
gentoo-59d9c1824d3b9a3200d298db15bd82ddb1c42987.tar.bz2
gentoo-59d9c1824d3b9a3200d298db15bd82ddb1c42987.zip
games-arcade/xscavenger: add 1.4.5, EAPI 7->8, remove imake
imake makes something that's very simple needlessly complicated, use an implicit make rule instead (fixes bug #739120). Updated old patch with references and more fixes (notably for garbled sub-menu text when using gcc7+). Also support prefix, add previously missing man page, and updated homepage. This version notably uses ALSA over /dev/dsp. Closes: https://bugs.gentoo.org/612812 Closes: https://bugs.gentoo.org/739120 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade/xscavenger/xscavenger-1.4.5.ebuild')
-rw-r--r--games-arcade/xscavenger/xscavenger-1.4.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-arcade/xscavenger/xscavenger-1.4.5.ebuild b/games-arcade/xscavenger/xscavenger-1.4.5.ebuild
new file mode 100644
index 000000000000..bb62ad68f021
--- /dev/null
+++ b/games-arcade/xscavenger/xscavenger-1.4.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic toolchain-funcs
+
+DESCRIPTION="Lode-Runner-like arcade game"
+HOMEPAGE="https://www.linuxmotors.com/linux/scavenger/index.html"
+SRC_URI="https://www.linuxmotors.com/linux/scavenger/downloads/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/alsa-lib
+ x11-libs/libX11"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-misc-fixes.patch
+)
+
+src_compile() {
+ tc-export CC
+
+ # skip using imake for simplicity
+ local cppargs=(
+ -DLIBNAME="'\"${EPREFIX}/usr/share/${PN}\"'"
+ $($(tc-getPKG_CONFIG) --cflags alsa x11)
+ )
+ append-cppflags "${cppargs[@]}"
+
+ LDLIBS="$($(tc-getPKG_CONFIG) --libs alsa x11)" \
+ emake -C src -E "scav: anim.o edit.o x.o sound.o"
+}
+
+src_install() {
+ newbin src/scav scavenger
+ doman src/scavenger.6
+
+ dodoc CREDITS DOC README TODO changelog
+
+ insinto /usr/share/${PN}
+ doins -r data/.
+
+ make_desktop_entry scavenger XScavenger applications-games
+}