summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-04 10:24:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-04 10:25:24 +0100
commit36ed429cd826bfc8341cf8c10bd5e704dcde5a3c (patch)
tree3e8b5b684400b46b4e22f97845e79b7b6a3549d2 /eclass
parentwww-client/firefox: stabilize 91.3.0 for amd64 (diff)
downloadgentoo-36ed429cd826bfc8341cf8c10bd5e704dcde5a3c.tar.gz
gentoo-36ed429cd826bfc8341cf8c10bd5e704dcde5a3c.tar.bz2
gentoo-36ed429cd826bfc8341cf8c10bd5e704dcde5a3c.zip
distutils-r1.eclass: Skip pyproject.toml check if DUS=manual
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass2
1 files changed, 2 insertions, 0 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 3513a74c4db4..46253759b1dc 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -610,6 +610,8 @@ _distutils-r1_disable_ez_setup() {
# @DESCRIPTION:
# Generate setup.py for pyproject.toml if requested.
_distutils-r1_handle_pyproject_toml() {
+ [[ ${DISTUTILS_USE_SETUPTOOLS} == manual ]] && return
+
if [[ ! -f setup.py && -f pyproject.toml ]]; then
if [[ ${DISTUTILS_USE_SETUPTOOLS} != pyproject.toml ]]; then
eerror "No setup.py found but pyproject.toml is present. In order to enable"