summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-11 01:17:27 +0000
committerSam James <sam@gentoo.org>2021-12-11 01:17:27 +0000
commite4b46346ff1f6a87a637640677d2cfd0f0905cbe (patch)
treea7b64bb4d83eff2c174ea7a34e028f52a2c6daa3 /dev-util/clazy/clazy-1.10.ebuild
parentnet-p2p/deluge: use PYTHON_SINGLE_USEDEP for libtorrent-rasterbar (diff)
downloadgentoo-e4b46346ff1f6a87a637640677d2cfd0f0905cbe.tar.gz
gentoo-e4b46346ff1f6a87a637640677d2cfd0f0905cbe.tar.bz2
gentoo-e4b46346ff1f6a87a637640677d2cfd0f0905cbe.zip
Revert "dev-util/clazy: use llvm.eclass to declare compatibility"
This reverts commit 15d1e9c51bee91279e79fad16777338e6aff1b8b. (Didn't mean to push yet, sorry!) Bug: https://bugs.gentoo.org/823726 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/clazy/clazy-1.10.ebuild')
-rw-r--r--dev-util/clazy/clazy-1.10.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/clazy/clazy-1.10.ebuild b/dev-util/clazy/clazy-1.10.ebuild
new file mode 100644
index 000000000000..160c50c5c641
--- /dev/null
+++ b/dev-util/clazy/clazy-1.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Compiler plugin which allows clang to understand Qt semantics"
+HOMEPAGE="https://apps.kde.org/clazy"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sys-devel/clang-8.0:=
+ >=sys-devel/llvm-8.0:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e '/install(FILES README.md COPYING-LGPL2.txt checks.json DESTINATION/d' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ # this package requires both llvm and clang of the same version.
+ # clang pulls in the equivalent llvm version, but not vice versa.
+ # so, we must find llvm based on the installed clang version.
+ # bug #681568
+ local clang_version=$(best_version "sys-devel/clang")
+ export LLVM_ROOT="/usr/lib/llvm/$(ver_cut 1 ${clang_version##sys-devel/clang-})"
+ cmake_src_configure
+}
+
+src_test() {
+ # Run tests against built copy, not installed
+ # bug #811723
+ PATH="${BUILD_DIR}/bin:${PATH}" LD_LIBRARY_PATH="${BUILD_DIR}/lib" cmake_src_test
+}