summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-17 19:44:22 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-17 19:44:52 +0100
commit3def5aac5dced458b28b32b54dd4391917e8da34 (patch)
treef8bf36822c63c2480ed7269bc42209915e4990fb /dev-tcltk
parentxfce-extra/xfce4-whiskermenu-plugin: Bump to 2.7.2 (diff)
downloadgentoo-3def5aac5dced458b28b32b54dd4391917e8da34.tar.gz
gentoo-3def5aac5dced458b28b32b54dd4391917e8da34.tar.bz2
gentoo-3def5aac5dced458b28b32b54dd4391917e8da34.zip
dev-tcltk/tkzinc: fix incomp pointer conversion
Closes: https://bugs.gentoo.org/871120 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tkzinc/files/tkzinc-3.3.6-clang.patch29
-rw-r--r--dev-tcltk/tkzinc/tkzinc-3.3.6-r1.ebuild5
2 files changed, 32 insertions, 2 deletions
diff --git a/dev-tcltk/tkzinc/files/tkzinc-3.3.6-clang.patch b/dev-tcltk/tkzinc/files/tkzinc-3.3.6-clang.patch
new file mode 100644
index 000000000000..e8bdb40b6083
--- /dev/null
+++ b/dev-tcltk/tkzinc/files/tkzinc-3.3.6-clang.patch
@@ -0,0 +1,29 @@
+--- a/generic/Window.c 2023-01-17 19:39:55.697886490 +0100
++++ b/generic/Window.c 2023-01-17 19:41:15.619618094 +0100
+@@ -350,7 +350,7 @@
+ #endif /* ifdef _WIN32 */
+
+ /* Reset externalwindow */
+- wind->externalwindow = NULL;
++ wind->externalwindow = 0;
+ }
+
+
+@@ -384,7 +384,7 @@
+ wind->connection_anchor = TK_ANCHOR_SW;
+ wind->win = NULL;
+ wind->windowtitle = NULL;
+- wind->externalwindow = NULL;
++ wind->externalwindow = 0;
+
+ return TCL_OK;
+ }
+@@ -407,7 +407,7 @@
+ */
+ wind->win = NULL;
+ wind->windowtitle = NULL;
+- wind->externalwindow = NULL;
++ wind->externalwindow = 0;
+ }
+
+
diff --git a/dev-tcltk/tkzinc/tkzinc-3.3.6-r1.ebuild b/dev-tcltk/tkzinc/tkzinc-3.3.6-r1.ebuild
index a94dde7d11fe..c7fa5fd154eb 100644
--- a/dev-tcltk/tkzinc/tkzinc-3.3.6-r1.ebuild
+++ b/dev-tcltk/tkzinc/tkzinc-3.3.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,7 +26,8 @@ S="${WORKDIR}/Tkzinc-${PV//.}+"
PATCHES=(
"${FILESDIR}"/${PV}-ldflags.patch
"${FILESDIR}"/${PN}-3.3.4-latex.patch
- )
+ "${FILESDIR}"/${P}-clang.patch
+)
HTML_DOCS='doc/*png doc/*html doc/*css'